aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTim Gardner <tim.gardner@canonical.com>2011-08-09 10:52:25 -0600
committerJohn Rigby <john.rigby@linaro.org>2011-09-12 09:08:49 -0600
commit3378289f702aefd1375b85044170e73f8b5c08ea (patch)
tree0e6bc47809895e50f5e250999d193647d9842849 /debian
parentad79ece52c153ce1101c2cb45b8e2a9634abeef9 (diff)
UBUNTU: [Config] Clean up tools rules
There is no stem '$*' with which to match the automatic variable '%'. Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/rules.d/2-binary-arch.mk14
1 files changed, 7 insertions, 7 deletions
diff --git a/debian/rules.d/2-binary-arch.mk b/debian/rules.d/2-binary-arch.mk
index c1515423fbc..c16459bab85 100644
--- a/debian/rules.d/2-binary-arch.mk
+++ b/debian/rules.d/2-binary-arch.mk
@@ -355,17 +355,17 @@ $(stampdir)/stamp-flavours:
$(stampdir)/stamp-prepare-perarch:
@echo "Preparing perarch ..."
ifeq ($(do_tools),true)
- rm -rf $(builddir)/tools-$*
- install -d $(builddir)/tools-$*
- for i in *; do ln -s $(CURDIR)/$$i $(builddir)/tools-$*/; done
- rm $(builddir)/tools-$*/tools
- rsync -a tools/ $(builddir)/tools-$*/tools/
+ rm -rf $(builddir)/tools
+ install -d $(builddir)/tools
+ for i in *; do ln -s $(CURDIR)/$$i $(builddir)/tools/; done
+ rm $(builddir)/tools/tools
+ rsync -a tools/ $(builddir)/tools/tools/
endif
touch $@
$(stampdir)/stamp-build-perarch: prepare-perarch
ifeq ($(do_tools),true)
- cd $(builddir)/tools-$*/tools/perf && make $(CROSS_COMPILE)
+ cd $(builddir)/tools/tools/perf && make $(CROSS_COMPILE)
endif
@touch $@
@@ -374,7 +374,7 @@ install-perarch: $(stampdir)/stamp-build-perarch
# Add the tools.
ifeq ($(do_tools),true)
install -d $(toolspkgdir)/usr/bin
- install -s -m755 $(builddir)/tools-$*/tools/perf/perf \
+ install -s -m755 $(builddir)/tools/tools/perf/perf \
$(toolspkgdir)/usr/bin/perf_$(abi_release)
endif