aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTim Gardner <tim.gardner@canonical.com>2011-08-22 10:00:45 -0600
committerJohn Rigby <john.rigby@linaro.org>2011-09-12 09:10:02 -0600
commit0cc0b8ca672beb7581223b27b091d8c05ef92765 (patch)
tree080325ab7eaac318469795f3a50b6885afa808b1 /debian
parentcfbfb5e68054c25c2d65c6f6748980924603b256 (diff)
UBUNTU: [Config] Linearize module/abi checks
The module and ABI checks are not independent, so make sure the modules check is dependent on the ABI check having been performed. Also drop some superfluous shortcuts along the way. Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/rules.d/2-binary-arch.mk2
-rw-r--r--debian/rules.d/4-checks.mk8
2 files changed, 3 insertions, 7 deletions
diff --git a/debian/rules.d/2-binary-arch.mk b/debian/rules.d/2-binary-arch.mk
index 27b39759a8d..06b24a24ac4 100644
--- a/debian/rules.d/2-binary-arch.mk
+++ b/debian/rules.d/2-binary-arch.mk
@@ -43,7 +43,7 @@ install-%: dbgpkgdir = $(CURDIR)/debian/$(bin_pkg_name)-$*-dbgsym
install-%: basepkg = $(hdrs_pkg_name)
install-%: hdrdir = $(CURDIR)/debian/$(basepkg)-$*/usr/src/$(basepkg)-$*
install-%: target_flavour = $*
-install-%: $(stampdir)/stamp-build-% checks-%
+install-%: checks-%
dh_testdir
dh_testroot
dh_clean -k -p$(bin_pkg_name)-$*
diff --git a/debian/rules.d/4-checks.mk b/debian/rules.d/4-checks.mk
index d48c05d6260..d1c0ad96683 100644
--- a/debian/rules.d/4-checks.mk
+++ b/debian/rules.d/4-checks.mk
@@ -1,6 +1,4 @@
# Check ABI for package against last release (if not same abinum)
-abi-%: $(abidir)/%
- @# Empty for make to be happy
$(abidir)/%: $(stampdir)/stamp-build-%
install -d $(abidir)
sed -e 's/^\(.\+\)[[:space:]]\+\(.\+\)[[:space:]]\(.\+\)$$/\3 \2 \1/' \
@@ -11,9 +9,7 @@ abi-check-%: $(abidir)/%
"$(prev_abidir)" "$(abidir)" "$(skipabi)"
# Check the module list against the last release (always)
-module-%: $(abidir)/%.modules
- @# Empty for make to be happy
-$(abidir)/%.modules: $(stampdir)/stamp-build-%
+$(abidir)/%.modules: abi-check-%
install -d $(abidir)
find $(builddir)/build-$*/ -name \*.ko | \
sed -e 's/.*\/\([^\/]*\)\.ko/\1/' | sort > $@
@@ -22,7 +18,7 @@ module-check-%: $(abidir)/%.modules
@perl -f $(DROOT)/scripts/module-check "$*" \
"$(prev_abidir)" "$(abidir)" $(skipmodule)
-checks-%: abi-check-% module-check-%
+checks-%: module-check-%
@# Will be calling more stuff later
# Check the config against the known options list.