aboutsummaryrefslogtreecommitdiff
path: root/lib/Format/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Jasper <djasper@google.com>2012-12-03 18:12:45 +0000
committerDaniel Jasper <djasper@google.com>2012-12-03 18:12:45 +0000
commitbac016bd3f67ca2f4db1ddc619e611759352b84d (patch)
tree82232dd80409934344e3f0c259da493e5fc35b0e /lib/Format/CMakeLists.txt
parent189f2e421d06526ea8b4a3dcd9f4a072e10a859c (diff)
Initial version of formatting library.
This formatting library will be used by a stand-alone clang-format tool and can also be used when writing other refactorings. Manuel's original design document: https://docs.google.com/a/google.com/document/d/1gpckL2U_6QuU9YW2L1ABsc4Fcogn5UngKk7fE5dDOoA/edit The library can already successfully format itself. Review: http://llvm-reviews.chandlerc.com/D80 git-svn-id: https://llvm.org/svn/llvm-project/cfe/trunk@169137 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'lib/Format/CMakeLists.txt')
-rw-r--r--lib/Format/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/lib/Format/CMakeLists.txt b/lib/Format/CMakeLists.txt
new file mode 100644
index 0000000000..60ab14da24
--- /dev/null
+++ b/lib/Format/CMakeLists.txt
@@ -0,0 +1,24 @@
+set(LLVM_LINK_COMPONENTS support)
+
+add_clang_library(clangFormat
+ UnwrappedLineParser.cpp
+ Format.cpp
+ )
+
+add_dependencies(clangFormat
+ ClangAttrClasses
+ ClangAttrList
+ ClangDeclNodes
+ ClangDiagnosticCommon
+ ClangDiagnosticFrontend
+ ClangStmtNodes
+ )
+
+target_link_libraries(clangFormat
+ clangBasic
+ clangFrontend
+ clangAST
+ clangASTMatchers
+ clangRewriteCore
+ clangRewriteFrontend
+ )