aboutsummaryrefslogtreecommitdiff
path: root/libio/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'libio/configure.in')
-rw-r--r--libio/configure.in93
1 files changed, 93 insertions, 0 deletions
diff --git a/libio/configure.in b/libio/configure.in
new file mode 100644
index 00000000000..d6359382bcf
--- /dev/null
+++ b/libio/configure.in
@@ -0,0 +1,93 @@
+# This file is a shell script fragment that supplies the information
+# necessary for a configure script to process the program in
+# this directory. For more information, look at ../configure.
+
+configdirs="tests dbz stdio testsuite"
+srctrigger=libioP.h
+srcname="input/output library"
+package_makefile_frag=Make.pack
+
+# per-host:
+
+# per-target:
+
+echo "# Warning: this fragment is automatically generated" > temp.mt
+frags=
+
+case "${target}" in
+ *-hpux*) frags=hpux.mt ;;
+ *-linux*)
+ echo "WARNING: The I/O implementation in FSF libg++ 2.8.x is not"
+ echo " compatible with Linux libc through 5.2.x."
+ echo " See libg++/README for more information."
+ echo " YOU ARE ON YOUR OWN!"
+ frags=linux.mt ;;
+ *-sco3.2v[45]*) frags=sco4.mt ;;
+ *-isc*) frags=isc.mt ;;
+ *-netware*) frags=netware.mt ;;
+ *) frags=${target_cpu}.mt ;;
+esac
+
+case "${enable_shared}" in
+ yes) shared=yes ;;
+ no) shared=no ;;
+ *libio*) shared=yes ;;
+ *) shared=no ;;
+esac
+
+if [ "${shared}" = "yes" ]; then
+ case "${target}" in
+ hppa*-*) frags="${frags} ../../config/mh-papic" ;;
+ i[3456]86-*) frags="${frags} ../../config/mh-x86pic" ;;
+ *) frags="${frags} ../../config/mh-${target_cpu}pic" ;;
+ esac
+fi
+
+for frag in ${frags}; do
+ frag=${srcdir}/config/$frag
+ if [ -f ${frag} ]; then
+ echo "Appending ${frag} to target-mkfrag"
+ echo "# Following fragment copied from ${frag}" >> temp.mt
+ cat ${frag} >> temp.mt
+ fi
+done
+
+target_makefile_frag=target-mkfrag
+${moveifchange} temp.mt target-mkfrag
+
+LIBDIR=yes
+TO_TOPDIR=../
+ALL='$(_G_CONFIG_H) libio.a iostream.list'
+XCINCLUDES='-I. -I$(srcdir)'
+XCXXINCLUDES='-I. -I$(srcdir)'
+MOSTLYCLEAN='*.o pic stamp-picdir core iostream.list'
+DISTCLEAN='config.status Makefile *~ Make.pack target-mkfrag multilib.out'
+CLEAN='_G_config.h *.a'
+INFO_FILES=iostream
+if [ -n "${with_cross_host}" ] ; then
+ CHECK_SUBDIRS=testsuite
+fi
+(. ${srcdir}/config.shared) >${package_makefile_frag}
+
+# post-target:
+
+# If cross-compiling, don't build gperf or the utils. They
+# will get built by the target compiler, which is confusing.
+# We cannot test the installation. We install in $(tooldir).
+if [ -n "${with_cross_host}" ] ; then
+ rm -f Makefile.tem
+ sed \
+ -e 's|INSTALLDIR.*=.*$|INSTALLDIR = $(tooldir)/lib|' \
+ Makefile >Makefile.tem
+ mv -f Makefile.tem Makefile
+fi
+
+if [ "${srcdir}" = "." ] ; then
+ if [ "${with_target_subdir}" != "." ] ; then
+ . ${with_multisrctop}../../config-ml.in
+ else
+ . ${with_multisrctop}../config-ml.in
+ fi
+else
+ . ${srcdir}/../config-ml.in
+fi