aboutsummaryrefslogtreecommitdiff
path: root/libiberty/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'libiberty/configure.in')
-rw-r--r--libiberty/configure.in66
1 files changed, 66 insertions, 0 deletions
diff --git a/libiberty/configure.in b/libiberty/configure.in
new file mode 100644
index 00000000000..b0020d8bab4
--- /dev/null
+++ b/libiberty/configure.in
@@ -0,0 +1,66 @@
+# This file is a shell script fragment that supplies the information
+# necessary for a configure script to process the program in
+# this directory. For more information, look at ../configure.
+
+configdirs=
+srctrigger=getopt1.c
+srcname="-liberty library"
+
+# per-host:
+
+files="alloca-norm.h"
+links="alloca-conf.h"
+
+. ${srcdir}/config.table
+host_makefile_frag=${frag}
+
+# per-target:
+
+# post-target:
+
+# If this is the target libiberty, check at compile time whether we are using
+# newlib. If we are, we already know the files we need, since the linker
+# will fail when run on some of the newlib targets.
+if [ -n "${with_target_subdir}" ] ; then
+ cat > Makefile.tem <<'!EOF!'
+CONFIG_H = xconfig.h
+NEEDED_LIST = xneeded-list
+
+xconfig.h: Makefile
+ if [ -f ../newlib/Makefile ]; then \
+ echo "#define NEED_sys_nerr 1" >xconfig.h; \
+ echo "#define NEED_sys_errlist 1" >>xconfig.h; \
+ echo "#define NEED_sys_siglist 1" >>xconfig.h; \
+ echo "#define NEED_strsignal 1" >>xconfig.h; \
+ echo "#define NEED_psignal 1" >>xconfig.h; \
+ else \
+ $(MAKE) $(FLAGS_TO_PASS) lconfig.h; \
+ cp lconfig.h xconfig.h; \
+ fi
+
+xneeded-list: Makefile
+ if [ -f ../newlib/Makefile ]; then \
+ echo insque.o random.o strdup.o alloca.o vasprintf.o >xneeded-list; \
+ else \
+ $(MAKE) $(FLAGS_TO_PASS) lneeded-list; \
+ cp lneeded-list xneeded-list; \
+ fi
+!EOF!
+sed -e "/^####/ r Makefile.tem" \
+ -e '/INSTALL_DEST =/s/libdir/tooldir/' ${Makefile} > Makefile.tem3
+mv Makefile.tem3 ${Makefile}
+rm -f Makefile.tem
+fi
+
+# We need multilib support, but only if configuring for the target.
+if [ -n "${with_target_subdir}" ] ; then
+ if [ "${srcdir}" = "." ] ; then
+ if [ "${with_target_subdir}" != "." ] ; then
+ . ${with_multisrctop}../../config-ml.in
+ else
+ . ${with_multisrctop}../config-ml.in
+ fi
+ else
+ . ${srcdir}/../config-ml.in
+ fi
+fi