aboutsummaryrefslogtreecommitdiff
path: root/libgomp/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'libgomp/configure.ac')
-rw-r--r--libgomp/configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/libgomp/configure.ac b/libgomp/configure.ac
index d6f960e3833..e42faccc391 100644
--- a/libgomp/configure.ac
+++ b/libgomp/configure.ac
@@ -21,6 +21,20 @@ LIBGOMP_ENABLE(linux-futex, default, ,
permit yes|no|default)
AC_MSG_RESULT($enable_linux_futex)
+# We would like our source tree to be readonly. However when releases or
+# pre-releases are generated, the flex/bison generated files as well as the
+# various formats of manuals need to be included along with the rest of the
+# sources. Therefore we have --enable-generated-files-in-srcdir to do
+# just that.
+AC_MSG_CHECKING([for --enable-generated-files-in-srcdir])
+LIBGOMP_ENABLE(generated-files-in-srcdir, no, ,
+ [put copies of generated files in source dir intended for creating source
+ tarballs for users without texinfo bison or flex.],
+ permit yes|no)
+AC_MSG_RESULT($enable_generated_files_in_srcdir)
+AM_CONDITIONAL(GENINSRC, test "$enable_generated_files_in_srcdir" = yes)
+
+
# -------
# -------