aboutsummaryrefslogtreecommitdiff
path: root/libjava/configure.in
diff options
context:
space:
mode:
authorbryce <bryce@138bc75d-0d04-0410-961f-82ee72b054a4>2000-11-26 01:48:04 +0000
committerbryce <bryce@138bc75d-0d04-0410-961f-82ee72b054a4>2000-11-26 01:48:04 +0000
commit225627d7c6bf030c419f926e56c45660dbd5bb9d (patch)
tree4eaca964f2a13f025b0393ee000372ef3380e323 /libjava/configure.in
parentace65efdcf04e82460a38b314b7341a795cb16c4 (diff)
2000-11-24 Bryce McKinlay <bryce@albatross.co.nz>
* java/lang/System.java (setProperties): Only call init_properties() if properties is null. (getProperties): Ditto. (getProperty): Ditto. (setProperty): Call init_properties if properties are null. (prop_init): Remove field. * java/lang/natSystem.cc (init_properties): Synchronize the entire method. Check for null properties after synchronizing instead of prop_init flag. Set the properties field last for thread safety. * java/io/ObjectInputStream.java (ObjectInputStream): If DEBUG is set, test for gcj.dumpobjects property and enable object stream dumping if it is set. (dumpElement): No longer native. (dumpElementln): Ditto. (setDump): Do not define. * java/io/natObjectInputStream.cc (dumpElement): Removed. (dumpElementln): Removed. (setDump): Removed. 2000-11-24 Bryce McKinlay <bryce@albatross.co.nz> * configure: Rebuilt. * Makefile.in: Rebuilt. * Makefile.am (built_java_source_files): Add Configuration.java. * configure.in: Add Configuration.java to CONFIG_FILES. Set LIBGCJDEBUG substitution if --enable-libgcj-debug is specified. Create `gnu' directory in the build tree. * gnu/classpath/Configuration.java.in: New file. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@37749 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/configure.in')
-rw-r--r--libjava/configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/libjava/configure.in b/libjava/configure.in
index 71154905212..7e0bbce3141 100644
--- a/libjava/configure.in
+++ b/libjava/configure.in
@@ -65,10 +65,13 @@ if test "$enable_getenv_properties" = no; then
fi
dnl See if the user has requested runtime debugging.
+LIBGCJDEBUG="false"
+AC_SUBST(LIBGCJDEBUG)
AC_ARG_ENABLE(libgcj-debug,
[ --enable-libgcj-debug enable runtime debugging code],
if test "$enable_libgcj_debug" = yes; then
- AC_DEFINE(DEBUG)
+ AC_DEFINE(DEBUG)
+ LIBGCJDEBUG="true"
fi)
dnl See if the user has the interpreter included.
@@ -173,6 +176,7 @@ dnl Create the subdirectory for natFileDescriptor.cc, or the attempt
dnl to create the link will fail.
test -d java || mkdir java
test -d java/io || mkdir java/io
+test -d gnu || mkdir gnu
AC_LINK_FILES(java/io/$FILE_DESCRIPTOR, java/io/natFileDescriptor.cc)
dnl Likewise for ConcreteProcess.java and natConcreteProcess.cc.
@@ -770,7 +774,7 @@ here=`pwd`
AC_SUBST(here)
-AC_OUTPUT(Makefile libgcj.spec libgcj-test.spec gcj/Makefile include/Makefile testsuite/Makefile,
+AC_OUTPUT(Makefile libgcj.spec libgcj-test.spec gnu/classpath/Configuration.java gcj/Makefile include/Makefile testsuite/Makefile,
[if test -n "$CONFIG_FILES"; then
ac_file=Makefile . ${libgcj_basedir}/../config-ml.in
fi