aboutsummaryrefslogtreecommitdiff
path: root/libgomp/configure.ac
diff options
context:
space:
mode:
authoramonakov <amonakov@138bc75d-0d04-0410-961f-82ee72b054a4>2016-11-30 18:08:30 +0000
committeramonakov <amonakov@138bc75d-0d04-0410-961f-82ee72b054a4>2016-11-30 18:08:30 +0000
commitb0d82200ad229480f73d8ec37ec20a70214908fd (patch)
treec5a2737c29a2282ad9665f202a1374c48bced574 /libgomp/configure.ac
parentebbb7f3d04d8e3064d75f3365f0b3156dcdaeaf3 (diff)
libgomp: introduce LIBGOMP_OFFLOADED_ONLY macro
* configure.ac [nvptx*-*-*] (libgomp_offloaded_only): Set and use it... (LIBGOMP_OFFLOADED_ONLY): ...here; new define. * configure: Regenerate. * config.h.in: Likewise. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@243040 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgomp/configure.ac')
-rw-r--r--libgomp/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/libgomp/configure.ac b/libgomp/configure.ac
index 5f1db7e1e0e..4086d3f8263 100644
--- a/libgomp/configure.ac
+++ b/libgomp/configure.ac
@@ -182,6 +182,8 @@ case "$host" in
nvptx*-*-*)
# NVPTX does not support Pthreads, has its own code replacement.
libgomp_use_pthreads=no
+ # NVPTX is an accelerator-only target
+ libgomp_offloaded_only=yes
;;
*)
# Check to see if -pthread or -lpthread is needed. Prefer the former.
@@ -208,6 +210,11 @@ if test x$libgomp_use_pthreads != xno; then
[Define to 1 if libgomp should use POSIX threads.])
fi
+if test x$libgomp_offloaded_only = xyes; then
+ AC_DEFINE(LIBGOMP_OFFLOADED_ONLY, 1,
+ [Define to 1 if building libgomp for an accelerator-only target.])
+fi
+
m4_include([plugin/configfrag.ac])
# Check for functions needed.