aboutsummaryrefslogtreecommitdiff
path: root/libgomp/configure.ac
diff options
context:
space:
mode:
authorandreast <andreast@138bc75d-0d04-0410-961f-82ee72b054a4>2006-01-23 18:28:51 +0000
committerandreast <andreast@138bc75d-0d04-0410-961f-82ee72b054a4>2006-01-23 18:28:51 +0000
commit138f59be670f9c73dfea48ac4153227f92e30ec7 (patch)
tree8d13fe4ae78bc89d5119bc9ac9a016ba1156ce77 /libgomp/configure.ac
parent6cf0bc8c8b789cc8045faebeb8ada8697e04e719 (diff)
2006-01-23 Andreas Tobler <a.tobler@schweiz.ch>
* config/posix/proc.c: Conditional include of sys/loadavg.h for Solaris. * configure.ac: Add check for loadavg.h. (link_gomp): Adjust comment. * configure: Regenerate. * config.h.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@110141 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgomp/configure.ac')
-rw-r--r--libgomp/configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/libgomp/configure.ac b/libgomp/configure.ac
index 854514a27f4..2a00337a57d 100644
--- a/libgomp/configure.ac
+++ b/libgomp/configure.ac
@@ -136,7 +136,7 @@ AC_SUBST(libtool_VERSION)
# Check header files.
AC_STDC_HEADERS
AC_HEADER_TIME
-AC_CHECK_HEADERS(unistd.h semaphore.h sys/time.h)
+AC_CHECK_HEADERS(unistd.h semaphore.h sys/loadavg.h sys/time.h)
AC_CHECK_HEADER([pthread.h],[],
[AC_MSG_ERROR([Pthreads are required to build libgomp])])
@@ -204,7 +204,7 @@ else
fi
# Set up the set of libraries that we need to link against for libgomp.
-# Note that the GOMP_DRIVER_SPEC in gcc.c will force -pthread for -fopenmp,
+# Note that the GOMP_SELF_SPEC in gcc.c will force -pthread for -fopenmp,
# which will force linkage against -lpthread (or equivalent for the system).
# That's not 100% ideal, but about the best we can do easily.
if test $enable_shared = yes; then