aboutsummaryrefslogtreecommitdiff
path: root/libgomp/Makefile.am
diff options
context:
space:
mode:
authorDaniel Franke <franke.daniel@gmail.com>2006-12-21 17:29:08 -0500
committerDaniel Franke <dfranke@gcc.gnu.org>2006-12-21 17:29:08 -0500
commit3721b9e1ee8b73b2e299fb2ce80568a35578e728 (patch)
tree431fe1679a89a4f2c4ce0e099c1c53dd39131c0d /libgomp/Makefile.am
parente9d207d9ac31509bbf6db4035b3784c74b47d669 (diff)
re PR libgomp/28209 (None of the GOMP_* environment variables are documented)
2006-12-21 Daniel Franke <franke.daniel@gmail.com> PR libgomp/28209 * libgomp.texi: New file. * configure.ac: Add --enable-generated-files-in-srcdir option. * Makefile.am: Add info, dvi, pdf, html targets. On request, copy files to srcdir. * Makefile.in: Regenerated. * config.h.in: Regenerated. * testsuite/Makefile.in: Regenerated. * NOTES: Removed. From-SVN: r120122
Diffstat (limited to 'libgomp/Makefile.am')
-rw-r--r--libgomp/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/libgomp/Makefile.am b/libgomp/Makefile.am
index 6e84a4b491e..ee2669c952f 100644
--- a/libgomp/Makefile.am
+++ b/libgomp/Makefile.am
@@ -50,7 +50,35 @@ fortran.o: libgomp_f.h
env.lo: libgomp_f.h
env.o: libgomp_f.h
+
# No install-html target
.PHONY: install-html
install-html:
+
+# Automake Documentation:
+# If your package has Texinfo files in many directories, you can use the
+# variable TEXINFO_TEX to tell Automake where to find the canonical
+# `texinfo.tex' for your package. The value of this variable should be
+# the relative path from the current `Makefile.am' to `texinfo.tex'.
+TEXINFO_TEX = ../gcc/doc/include/texinfo.tex
+
+# Defines info, dvi, pdf and html targets
+MAKEINFOFLAGS = -I $(srcdir)/../gcc/doc/include
+info_TEXINFOS = libgomp.texi
+
+# AM_CONDITIONAL on configure option --generated-files-in-srcdir
+if GENINSRC
+STAMP_GENINSRC = stamp-geninsrc
+else
+STAMP_GENINSRC =
+endif
+
+all-local: $(STAMP_GENINSRC)
+
+stamp-geninsrc: libgomp.info
+ -cp -p $(top_builddir)/libgomp.info $(srcdir)/libgomp.info
+ touch $@
+
+CLEANFILES = stamp-geninsrc libgomp.info
+MAINTAINERCLEANFILES = $(srcdir)/libgomp.info