aboutsummaryrefslogtreecommitdiff
path: root/libgo/configure.ac
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2015-11-21 01:27:44 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2015-11-21 01:27:44 +0000
commit2b19d6878472189bbd622199ca90f23fb7f5129d (patch)
treece90880ae1cd1318680980381769544c90f941c8 /libgo/configure.ac
parent30adea30570840d9b4bcbd1cf7786f19ecf2e06d (diff)
PR go/66574
runtime: Use clock_gettime to get current time. Fetch the current time in nanoseconds, not microseconds, by using clock_gettime rather than gettimeofday. Update golang/go#11222. Fixes https://gcc.gnu.org/PR66574. Reviewed-on: https://go-review.googlesource.com/17156 git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@230694 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgo/configure.ac')
-rw-r--r--libgo/configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/libgo/configure.ac b/libgo/configure.ac
index 6e23a85fa6d..6eddb860974 100644
--- a/libgo/configure.ac
+++ b/libgo/configure.ac
@@ -501,9 +501,10 @@ PTHREAD_LIBS=
AC_CHECK_LIB([pthread], [pthread_create], PTHREAD_LIBS=-lpthread)
AC_SUBST(PTHREAD_LIBS)
-dnl Test if -lrt is required for sched_yield and/or nanosleep.
+dnl Test if -lrt is required for sched_yield or nanosleep or clock_gettime.
AC_SEARCH_LIBS([sched_yield], [rt])
AC_SEARCH_LIBS([nanosleep], [rt])
+AC_SEARCH_LIBS([clock_gettime], [rt])
AC_C_BIGENDIAN