aboutsummaryrefslogtreecommitdiff
path: root/libgo/configure.ac
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2013-02-05 22:22:17 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2013-02-05 22:22:17 +0000
commit6222f4a828548c0188ede626ded81d1f307803cc (patch)
tree41af694846a1bfc8719f9e3c0aeb2200cceb969f /libgo/configure.ac
parent4f364235dcb67b1953b21be78391110b4c633e1b (diff)
PR go/56017
libgo: Use DejaGNU when testing a cross-compiler. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@195766 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgo/configure.ac')
-rw-r--r--libgo/configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/libgo/configure.ac b/libgo/configure.ac
index 6cc2307bc52..761fb82c5db 100644
--- a/libgo/configure.ac
+++ b/libgo/configure.ac
@@ -156,6 +156,17 @@ AM_CONDITIONAL(LIBGO_IS_RTEMS, test $is_rtems = yes)
AM_CONDITIONAL(LIBGO_IS_SOLARIS, test $is_solaris = yes)
AC_SUBST(GOOS)
+dnl Test whether we need to use DejaGNU or whether we can use the
+dnl simpler gotest approach. We can only use gotest for a native
+dnl build.
+USE_DEJAGNU=no
+case ${host} in
+ *-*-rtems*) USE_DEJAGNU=yes ;;
+ ${target}) ;;
+ *) USE_DEJAGNU=yes ;;
+esac
+AC_SUBST(USE_DEJAGNU)
+
dnl N.B. Keep in sync with gcc/testsuite/go.test/go-test.exp (go-set-goarch).
is_386=no
is_alpha=no