aboutsummaryrefslogtreecommitdiff
path: root/libgo/configure.ac
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2012-02-08 22:35:30 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2012-02-08 22:35:30 +0000
commit5b49fca6e9dbefea4e75e66b748a371fb8714928 (patch)
tree4a8dab4b58205b5450ab14c370dd544cc25f9a09 /libgo/configure.ac
parent244c529e5238ec044a6de328494b45b7e2aa62f9 (diff)
runtime: Add matherr function when appropriate.
git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@184024 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgo/configure.ac')
-rw-r--r--libgo/configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/libgo/configure.ac b/libgo/configure.ac
index 155a412ee68..67789032868 100644
--- a/libgo/configure.ac
+++ b/libgo/configure.ac
@@ -478,6 +478,11 @@ AC_CHECK_FUNCS(sem_timedwait)
CFLAGS="$CFLAGS_hold"
LIBS="$LIBS_hold"
+LIBS_hold="$LIBS"
+LIBS="$LIBS $MATH_LIBS"
+AC_CHECK_FUNCS(matherr)
+LIBS="$LIBS_hold"
+
AC_CACHE_CHECK([for __sync_bool_compare_and_swap_4],
[libgo_cv_func___sync_bool_compare_and_swap_4],
[AC_LINK_IFELSE([
@@ -566,6 +571,16 @@ AC_CACHE_CHECK([epoll_event data.fd offset],
STRUCT_EPOLL_EVENT_FD_OFFSET=${libgo_cv_c_epoll_event_fd_offset}
AC_SUBST(STRUCT_EPOLL_EVENT_FD_OFFSET)
+dnl See if struct exception is defined in <math.h>.
+AC_CHECK_TYPE([struct exception],
+[libgo_has_struct_exception=yes],
+[libgo_has_struct_exception=no],
+[#include <math.h>])
+if test "$libgo_has_struct_exception" = "yes"; then
+ AC_DEFINE(HAVE_STRUCT_EXCEPTION, 1,
+ [Define to 1 if <math.h> defines struct exception])
+fi
+
dnl See whether setcontext changes the value of TLS variables.
AC_CACHE_CHECK([whether setcontext clobbers TLS variables],
[libgo_cv_lib_setcontext_clobbers_tls],