aboutsummaryrefslogtreecommitdiff
path: root/libgo/Makefile.am
diff options
context:
space:
mode:
authorIan Lance Taylor <ian@gcc.gnu.org>2019-12-06 19:52:46 +0000
committerIan Lance Taylor <ian@gcc.gnu.org>2019-12-06 19:52:46 +0000
commiteff6af8e0e9d750e13bedbe40ba70c395ba6234c (patch)
tree39b51e53686cb4555ad1fd17ac2127d15422c63e /libgo/Makefile.am
parent5ec7a413d154508c70cf4570ee8da0a545bd6b4a (diff)
re PR go/92820 (libgo.so.15 has executable stack)
PR go/92820 runtime: only build go-context for x86 GNU/Linux Reviewed-on: https://go-review.googlesource.com/c/gofrontend/+/210258 From-SVN: r279063
Diffstat (limited to 'libgo/Makefile.am')
-rw-r--r--libgo/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/libgo/Makefile.am b/libgo/Makefile.am
index 1192b449781..1700941d93c 100644
--- a/libgo/Makefile.am
+++ b/libgo/Makefile.am
@@ -414,6 +414,13 @@ else
rtems_task_variable_add_file =
endif
+runtime_context_asm_file =
+if LIBGO_IS_X86
+if LIBGO_IS_LINUX
+runtime_context_asm_file += runtime/go-context.S
+endif
+endif
+
runtime_files = \
runtime/aeshash.c \
runtime/go-assert.c \
@@ -445,7 +452,7 @@ runtime_files = \
runtime/runtime_c.c \
runtime/stack.c \
runtime/yield.c \
- runtime/go-context.S \
+ $(runtime_context_asm_file) \
$(rtems_task_variable_add_file)
version.go: s-version; @true