aboutsummaryrefslogtreecommitdiff
path: root/libgo/Makefile.am
diff options
context:
space:
mode:
authorIan Lance Taylor <ian@gcc.gnu.org>2017-11-21 06:19:10 +0000
committerIan Lance Taylor <ian@gcc.gnu.org>2017-11-21 06:19:10 +0000
commitc9548fa4f1c1eaee8d5760632d2f47c649f25238 (patch)
treeebbdafbaed8438eccfc128024fa0f2afb065c26c /libgo/Makefile.am
parent5e43a9eeca114f99248c46495449d6fd4fc2b63e (diff)
libgo: fix makefile buglet
Fix a small bug in the libgo Makefile recipe that constructs the directory from which to pick up libgcc_s.so ; the gccgo invocation with -print-libgcc-file-name was missing the flags, which meant that for -m32 builds we'd see the 64-bit libgcc dir. Reviewed-on: https://go-review.googlesource.com/78836 From-SVN: r254984
Diffstat (limited to 'libgo/Makefile.am')
-rw-r--r--libgo/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libgo/Makefile.am b/libgo/Makefile.am
index f0ecf92ca7d..7be49973f95 100644
--- a/libgo/Makefile.am
+++ b/libgo/Makefile.am
@@ -1001,7 +1001,7 @@ CHECK = \
export MAKE; \
NM="$(NM)"; \
export NM; \
- libgccdir=`${GOC} -print-libgcc-file-name | sed -e 's|/[^/]*$$||'`; \
+ libgccdir=`${GOC} ${GOCFLAGS} -print-libgcc-file-name | sed -e 's|/[^/]*$$||'`; \
LD_LIBRARY_PATH="`${PWD_COMMAND}`/.libs:$${libgccdir}:${LD_LIBRARY_PATH}"; \
LD_LIBRARY_PATH=`echo $${LD_LIBRARY_PATH} | sed 's,::*,:,g;s,^:*,,;s,:*$$,,'`; \
export LD_LIBRARY_PATH; \