aboutsummaryrefslogtreecommitdiff
path: root/libgfortran/configure.ac
diff options
context:
space:
mode:
authorsje <>2005-09-27 20:12:52 +0000
committersje <>2005-09-27 20:12:52 +0000
commit16d8350e625a21495b82387748b0b9535b3fe78e (patch)
treeb153488273b3833bfdf44f1f0c3ac72e033b31c2 /libgfortran/configure.ac
parent66d5e3dc022a4566247d9b30cf766bf96303d43d (diff)
PR target/23552
* acinclude.m4 (LIBGFOR_CHECK_FOR_BROKEN_ISFINITE): New. (LIBGFOR_CHECK_FOR_BROKEN_ISNAN): New. (LIBGFOR_CHECK_FOR_BROKEN_FPCLASSIFY): New. * configure.ac (LIBGFOR_CHECK_FOR_BROKEN_ISFINITE): Add use. (LIBGFOR_CHECK_FOR_BROKEN_ISNAN): Add use. (LIBGFOR_CHECK_FOR_BROKEN_FPCLASSIFY): Add use. * configure: Regenerate. * config.h.in: Regenerate. * libgfortan.h (isfinite): undef if broken, set if needed. (isnan): undef if broken, set if needed. (fpclassify): undef if broken, set if needed. * io/write.c: Remove TODO comment about working isfinite. * intrinsics/c99_functions.c (round): Use isfinite instead of fpclassify. * intrinsics/c99_functions.c (roundf): Ditto.
Diffstat (limited to 'libgfortran/configure.ac')
-rw-r--r--libgfortran/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
index ebd17b193b1..65f62416374 100644
--- a/libgfortran/configure.ac
+++ b/libgfortran/configure.ac
@@ -328,6 +328,15 @@ AC_CHECK_LIB([m],[ynl],[AC_DEFINE([HAVE_YNL],[1],[libm includes ynl])])
# On AIX, clog is present in libm as __clog
AC_CHECK_LIB([m],[__clog],[AC_DEFINE([HAVE_CLOG],[1],[libm includes clog])])
+# Check for a isfinite macro that works on long doubles.
+LIBGFOR_CHECK_FOR_BROKEN_ISFINITE
+
+# Check for a isnan macro that works on long doubles.
+LIBGFOR_CHECK_FOR_BROKEN_ISNAN
+
+# Check for a fpclassify macro that works on long doubles.
+LIBGFOR_CHECK_FOR_BROKEN_FPCLASSIFY
+
# Fallback in case isfinite is not available.
AC_CHECK_LIB([m],[finite],[AC_DEFINE([HAVE_FINITE],[1],[libm includes finite])])