aboutsummaryrefslogtreecommitdiff
path: root/libgfortran/configure.ac
diff options
context:
space:
mode:
authorsje <sje@138bc75d-0d04-0410-961f-82ee72b054a4>2013-11-15 17:50:28 +0000
committersje <sje@138bc75d-0d04-0410-961f-82ee72b054a4>2013-11-15 17:50:28 +0000
commitcec5cd66889f3f2d39de8dc70742f17a3b9d0778 (patch)
tree6fad6b53e6172c8c9f3beb223f4cf7dde903a7e1 /libgfortran/configure.ac
parent822f2c1b9c66a9f339da34912fd0375949b73a21 (diff)
2013-11-15 Steve Ellcey <sellcey@mips.com>
* configure.ac: Do not define HAVE_STRTOLD. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@204855 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgfortran/configure.ac')
-rw-r--r--libgfortran/configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
index 6417373404f..6acc0f29429 100644
--- a/libgfortran/configure.ac
+++ b/libgfortran/configure.ac
@@ -267,12 +267,18 @@ if test "x${with_newlib}" = "xyes"; then
# link executables.
AC_DEFINE(HAVE_MKSTEMP, 1, [Define if you have mkstemp.])
AC_DEFINE(HAVE_STRTOF, 1, [Define if you have strtof.])
- AC_DEFINE(HAVE_STRTOLD, 1, [Define if you have strtold.])
AC_DEFINE(HAVE_SNPRINTF, 1, [Define if you have snprintf.])
AC_DEFINE(HAVE_STRCASESTR, 1, [Define if you have strcasestr.])
AC_DEFINE(HAVE_VSNPRINTF, 1, [Define if you have vsnprintf.])
AC_DEFINE(HAVE_LOCALTIME_R, 1, [Define if you have localtime_r.])
AC_DEFINE(HAVE_GMTIME_R, 1, [Define if you have gmtime_r.])
+
+ # At some point, we should differentiate between architectures
+ # like x86, which have long double versions, and alpha/powerpc/etc.,
+ # which don't. For the time being, punt.
+ if test x"long_double_math_on_this_cpu" = x"yes"; then
+ AC_DEFINE(HAVE_STRTOLD, 1, [Define if you have strtold.])
+ fi
else
AC_CHECK_FUNCS_ONCE(getrusage times mkstemp strtof strtold snprintf \
ftruncate chsize chdir getlogin gethostname kill link symlink sleep ttyname \