aboutsummaryrefslogtreecommitdiff
path: root/libgfortran/configure.ac
diff options
context:
space:
mode:
authorjb <jb@138bc75d-0d04-0410-961f-82ee72b054a4>2014-10-20 07:53:37 +0000
committerjb <jb@138bc75d-0d04-0410-961f-82ee72b054a4>2014-10-20 07:53:37 +0000
commit7f0d992b62e64e043b544dd36596a9b218423dc7 (patch)
treeca6deadcd02431554c183b307d7d10cc4ef3a6af /libgfortran/configure.ac
parent881bdfe36ad91e1d0b49a2586b04fa0c858f66b4 (diff)
PR 63589 Fix splitting of PATH in find_addr2line.
2014-10-20 Janne Blomqvist <jb@gcc.gnu.org> PR libfortran/63589 * configure.ac: Check for strtok_r. * runtime/main.c (gfstrtok_r): Fallback implementation of strtok_r. (find_addr2line): Use strtok_r to split PATH. * config.h.in: Regenerated. * configure: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@216449 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgfortran/configure.ac')
-rw-r--r--libgfortran/configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
index 9d8e05cdef6..b3150f49c99 100644
--- a/libgfortran/configure.ac
+++ b/libgfortran/configure.ac
@@ -275,6 +275,7 @@ if test "x${with_newlib}" = "xyes"; then
AC_DEFINE(HAVE_GMTIME_R, 1, [Define if you have gmtime_r.])
AC_DEFINE(HAVE_STRNLEN, 1, [Define if you have strnlen.])
AC_DEFINE(HAVE_STRNDUP, 1, [Define if you have strndup.])
+ AC_DEFINE(HAVE_STRTOK_R, 1, [Define if you have strtok_r.])
# At some point, we should differentiate between architectures
# like x86, which have long double versions, and alpha/powerpc/etc.,
@@ -289,7 +290,7 @@ else
strcasestr getrlimit gettimeofday stat fstat lstat getpwuid vsnprintf dup \
getcwd localtime_r gmtime_r getpwuid_r ttyname_r clock_gettime \
readlink getgid getpid getppid getuid geteuid umask getegid \
- secure_getenv __secure_getenv mkostemp strnlen strndup)
+ secure_getenv __secure_getenv mkostemp strnlen strndup strtok_r)
fi
# Check strerror_r, cannot be above as versions with two and three arguments exist