aboutsummaryrefslogtreecommitdiff
path: root/libgfortran/configure.ac
diff options
context:
space:
mode:
authorjb <jb@138bc75d-0d04-0410-961f-82ee72b054a4>2014-09-30 20:05:33 +0000
committerjb <jb@138bc75d-0d04-0410-961f-82ee72b054a4>2014-09-30 20:05:33 +0000
commit68efaae8912f0b3fcb4f14c65cd11d3ff94769f6 (patch)
treef932be01b42f1b7ed3242c3c600cc2eb3b99acfc /libgfortran/configure.ac
parentd6084a96ea108f77a93910174b395020d13cd963 (diff)
Add -Werror=implicit-function-declaration to AM_CFLAGS.
2014-09-30 Janne Blomqvist <jb@gcc.gnu.org> * configure.ac (AM_CFLAGS): Add -Werror=implicit-function-declaration. * Makefile.in: Regenerated. * aclocal.m4: Regenerated. * configure: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@215741 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgfortran/configure.ac')
-rw-r--r--libgfortran/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/libgfortran/configure.ac b/libgfortran/configure.ac
index be4b7beba04..9d8e05cdef6 100644
--- a/libgfortran/configure.ac
+++ b/libgfortran/configure.ac
@@ -142,7 +142,7 @@ if test "x$GCC" = "xyes"; then
## We like to use C11 and C99 routines when available. This makes
## sure that
## __STDC_VERSION__ is set such that libc includes make them available.
- AM_CFLAGS="-std=gnu11 -Wall -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition -Wextra -Wwrite-strings"
+ AM_CFLAGS="-std=gnu11 -Wall -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition -Wextra -Wwrite-strings -Werror=implicit-function-declaration"
## Compile the following tests with the same system header contents
## that we'll encounter when compiling our own source files.
CFLAGS="-std=gnu11 $CFLAGS"