aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>2006-11-20 00:57:02 +0000
committerghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>2006-11-20 00:57:02 +0000
commitb7ba4196fbea3e3849c7e45671b69d99797d8d2d (patch)
tree54d914ffd07b95ae76d8ac3bdcb1d883c1a02a89 /configure.in
parenta1d2bede4ac0eddc7e42ddf4fae45826657aaf20 (diff)
* configure.in (--with-mpfr-dir): Also look in .libs and _libs for
libmpfr.a. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/branches/gcc-4_2-branch@119008 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index d9244530e33..e3914a8220b 100644
--- a/configure.in
+++ b/configure.in
@@ -1058,7 +1058,13 @@ AC_ARG_WITH(mpfr-dir, [ --with-mpfr-dir=PATH Specify source directory for MP
if test "x$with_mpfr_dir" != x; then
gmpinc="-I$with_mpfr_dir"
- gmplibs="$with_mpfr_dir/libmpfr.a"
+ if test -f "$with_mpfr_dir/.libs/libmpfr.a"; then
+ gmplibs="$with_mpfr_dir/.libs/libmpfr.a"
+ elif test -f "$with_mpfr_dir/_libs/libmpfr.a"; then
+ gmplibs="$with_mpfr_dir/_libs/libmpfr.a"
+ else
+ gmplibs="$with_mpfr_dir/libmpfr.a"
+ fi
else
gmplibs="-lmpfr"
fi