aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2003-06-11 03:04:44 +0000
committerneroden <neroden@138bc75d-0d04-0410-961f-82ee72b054a4>2003-06-11 03:04:44 +0000
commit622c1fa95d6da48f7064b6d4d93b0c59e782348b (patch)
tree27cebd7ea287cae60ac3ac5e39012775e96fc239 /configure.in
parent3d74d6689db567da1bbaffd835c68da3377d69b0 (diff)
* configure.in: Disable serial configure by default.
* configure: Regenerate. * Makefile.tpl: Abolish .NOTPARALLEL. * Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@67747 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 14 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index ba9c3bfcb80..f9c631c5c7a 100644
--- a/configure.in
+++ b/configure.in
@@ -1698,18 +1698,25 @@ AC_SUBST_FILE(maybe_dependencies)
# Create the serialization dependencies. This uses a temporary file.
AC_ARG_ENABLE([serial-configure],
-[ --disable-serial-[{host,target,build}-]configure
- Don't force sequential configuration of
+[ --enable-serial-[{host,target,build}-]configure
+ Force sequential configuration of
sub-packages for the host, target or build
- machine, or of any sub-packages at all])
+ machine, or all sub-packages])
+
+case ${enable_serial_configure} in
+ yes)
+ enable_serial_build_configure=yes
+ enable_serial_host_configure=yes
+ enable_serial_target_configure=yes
+ ;;
+esac
# These force 'configure's to be done one at a time, to avoid problems
# with contention over a shared config.cache.
rm -f serdep.tmp
echo '# serdep.tmp' > serdep.tmp
olditem=
-test "x${enable_serial_configure}" = xno ||
-test "x${enable_serial_build_configure}" = xno ||
+test "x${enable_serial_build_configure}" = xyes &&
for item in ${build_configdirs} ; do
case ${olditem} in
"") ;;
@@ -1718,8 +1725,7 @@ for item in ${build_configdirs} ; do
olditem=${item}
done
olditem=
-test "x${enable_serial_configure}" = xno ||
-test "x${enable_serial_host_configure}" = xno ||
+test "x${enable_serial_host_configure}" = xyes &&
for item in ${configdirs} ; do
case ${olditem} in
"") ;;
@@ -1728,8 +1734,7 @@ for item in ${configdirs} ; do
olditem=${item}
done
olditem=
-test "x${enable_serial_configure}" = xno ||
-test "x${enable_serial_target_configure}" = xno ||
+test "x${enable_serial_target_configure}" = xyes &&
for item in ${target_configdirs} ; do
case ${olditem} in
"") ;;