aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJim Wilson <wilson@gcc.gnu.org>1997-09-11 16:44:33 -0700
committerJim Wilson <wilson@gcc.gnu.org>1997-09-11 16:44:33 -0700
commitf401679ee13670ae1201150c0ac1ff22b7b64f0a (patch)
treef3be9c5ce95407e10452ad4e3179c546a5808a93 /configure.in
parent2e384318d3c58066fc1efbd3a74f71738af04758 (diff)
Patches from H.J. Lu for alpha-linux -fPIC --enable-shared problem.
* Makefile.in (local-distclean): Also remove mh-frag mt-frag. * configure.in (skipdirs): Add target-librx for Linux. (alpha-*-linux*): Use config/mh-elfalphapic and config/mt-elfalphapic. * mh-elfalphapic, mt-elfalphapic: New files. From-SVN: r15419
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 642461cf929..f48c2a91698 100644
--- a/configure.in
+++ b/configure.in
@@ -192,6 +192,7 @@ if [ x${shared} = xyes ]; then
i[3456]86-*) waugh=config/mh-x86pic ;;
sparc64-*) waugh=config/mh-sparcpic ;;
powerpc*-*) waugh=config/mh-ppcpic ;;
+ alpha-*-linux*) waugh=config/mh-elfalphapic ;;
*) waugh=config/mh-${host_cpu}pic ;;
esac
if [ -f ${srcdir}/${waugh} ]; then
@@ -455,6 +456,10 @@ case "${target}" in
# but don't build gdb
noconfigdirs="$noconfigdirs gdb target-libg++ target-libstdc++ target-libio target-librx"
;;
+ *-*-linux*)
+ # linux has rx in libc
+ skipdirs="$skipdirs target-librx"
+ ;;
*-*-cygwin32)
target_configdirs="$target_configdirs target-winsup"
noconfigdirs="$noconfigdirs expect target-libgloss"
@@ -759,6 +764,7 @@ if [ x${shared} = xyes ]; then
hppa*) target_makefile_frag=config/mt-papic ;;
i[3456]86-*) target_makefile_frag=config/mt-x86pic ;;
powerpc*-*) target_makefile_frag=config/mt-ppcpic ;;
+ alpha-*-linux*) target_makefile_frag=config/mt-elfalphapic ;;
*) target_makefile_frag=config/mt-${target_cpu}pic ;;
esac
fi