aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorromangareev <romangareev@138bc75d-0d04-0410-961f-82ee72b054a4>2014-08-18 15:42:11 +0000
committerromangareev <romangareev@138bc75d-0d04-0410-961f-82ee72b054a4>2014-08-18 15:42:11 +0000
commit429cca5154707b85df6b5b7a678441fdf8fd9b8a (patch)
treea353a3d31ffda81ef6d90612de9127c49b5fe3d1 /configure.ac
parent95e631b86f0f367b7cbb4ef744b238576885e587 (diff)
* configure.ac: Eliminate ClooG installation dependency.
* configure: Regenerate. * Makefile.tpl: Add definition of ISLLIBS and HOST_ISLLIBS. * Makefile.in: Regenerate. [config/] * cloog.m4: Remove the path to isllibs from clooglibs. * isl.m4: Add paths to islinc, isllibs. [gcc/] * Makefile.in: Add definition of ISLLIBS, HOST_ISLLIBS. * config.in: Add undef of HAVE_isl. * configure: Regenerate. * configure.ac: Add definition of HAVE_isl. * graphite-blocking.c: Add checking of HAVE_isl. * graphite-dependences.c: Likewise. * graphite-interchange.c: Likewise. * graphite-isl-ast-to-gimple.c: Likewise. * graphite-optimize-isl.c: Likewise. * graphite-poly.c: Likewise. * graphite-scop-detection.c: Likewise. * graphite-sese-to-poly.c: Likewise. * graphite.c: Likewise. * toplev.c: Replace the checking of HAVE_cloog with the checking of HAVE_isl. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@214106 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 16 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 163de5f7220..8f747d62c72 100644
--- a/configure.ac
+++ b/configure.ac
@@ -132,7 +132,7 @@ build_libs="build-libiberty"
build_tools="build-texinfo build-flex build-bison build-m4 build-fixincludes"
# these libraries are used by various programs built for the host environment
-#
+#f
host_libs="intl libiberty opcodes bfd readline tcl tk itcl libgui zlib libbacktrace libcpp libdecnumber gmp mpfr mpc isl cloog libelf libiconv"
# these tools are built for the host environment
@@ -1644,10 +1644,9 @@ AC_ARG_WITH(isl,
Equivalent to --with-isl-include=PATH/include
plus --with-isl-lib=PATH/lib])])
-# Treat either --without-cloog or --without-isl as a request to disable
+# Treat --without-isl as a request to disable
# GRAPHITE support and skip all following checks.
-if test "x$with_isl" != "xno" &&
- test "x$with_cloog" != "xno"; then
+if test "x$with_isl" != "xno"; then
# Check for ISL
dnl Provide configure switches and initialize islinc & isllibs
dnl with user input.
@@ -1672,11 +1671,9 @@ if test "x$with_isl" != "xno" &&
fi
fi
-# If either the ISL or the CLooG check failed, disable builds of in-tree
-# variants of both
+# If the ISL check failed, disable builds of in-tree
+# variants of both ISL and CLooG
if test "x$with_isl" = xno ||
- test "x$with_cloog" = xno ||
- test "x$gcc_cv_cloog" = xno ||
test "x$gcc_cv_isl" = xno; then
noconfigdirs="$noconfigdirs cloog isl"
islinc=
@@ -1684,11 +1681,20 @@ if test "x$with_isl" = xno ||
clooglibs=
fi
+# If the CLooG check failed, disable builds of in-tree
+# variants of CLooG
+if test "x$with_cloog" = xno ||
+ test "x$gcc_cv_cloog" = xno; then
+ noconfigdirs="$noconfigdirs cloog isl"
+ clooginc=
+ clooglibs=
+fi
+
+AC_SUBST(isllibs)
AC_SUBST(islinc)
AC_SUBST(clooglibs)
AC_SUBST(clooginc)
-
# Check for LTO support.
AC_ARG_ENABLE(lto,
[AS_HELP_STRING([--enable-lto], [enable link time optimization support])],
@@ -2812,7 +2818,7 @@ changequote(,)
changequote([,])
case $lib in
- mpc | mpfr | gmp | cloog)
+ mpc | mpfr | gmp | isl | cloog)
# If we're processing --with-$lib, --with-$lib-include or
# --with-$lib-lib, for one of the libs above, and target is
# different from host, don't pass the current argument to any