aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorrguenth <rguenth@138bc75d-0d04-0410-961f-82ee72b054a4>2013-01-14 15:01:13 +0000
committerrguenth <rguenth@138bc75d-0d04-0410-961f-82ee72b054a4>2013-01-14 15:01:13 +0000
commitb5e1d8ce7092358f1429519d62a0f47052e482ed (patch)
tree219645a4804abcaa9d6dc4dc693dbd4758a7a993 /configure.ac
parent66366b9623d4709c039e2971aaa2c35a8ceeae8f (diff)
2013-01-14 Richard Biener <rguenther@suse.de>
* configure.ac (cloog/isl): Also allow ISL 0.11.x and CLooG 0.18.0. * configure: Re-generate git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@195150 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 02720ee1b15..739cdc786cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1606,8 +1606,11 @@ if test "x$with_isl" != "xno" &&
dnl Provide configure switches and initialize islinc & isllibs
dnl with user input.
ISL_INIT_FLAGS
- dnl The minimal version of ISL required for Graphite.
+ dnl The versions of ISL that work for Graphite
ISL_CHECK_VERSION(0,10)
+ if test "${gcc_cv_isl}" = no ; then
+ ISL_CHECK_VERSION(0,11)
+ fi
dnl Only execute fail-action, if ISL has been requested.
ISL_IF_FAILED([
AC_MSG_ERROR([Unable to find a usable ISL. See config.log for details.])])
@@ -1617,11 +1620,11 @@ if test "x$with_isl" != "xno" &&
dnl Provide configure switches and initialize clooginc & clooglibs
dnl with user input.
CLOOG_INIT_FLAGS
- dnl The minimal version of CLooG required for Graphite.
- dnl
- dnl If we use CLooG-Legacy, the provided version information is
- dnl ignored.
+ dnl The versions of CLooG that work for Graphite.
CLOOG_CHECK_VERSION(0,17,0)
+ if test "${gcc_cv_cloog}" = no ; then
+ CLOOG_CHECK_VERSION(0,18,0)
+ fi
dnl Only execute fail-action, if CLooG has been requested.
CLOOG_IF_FAILED([