aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorjason <jason@138bc75d-0d04-0410-961f-82ee72b054a4>2015-05-26 12:29:13 +0000
committerjason <jason@138bc75d-0d04-0410-961f-82ee72b054a4>2015-05-26 12:29:13 +0000
commit27590679c6484ad8cb1113da399f866ada356fdf (patch)
treeb2c58825207b709d6973d425a1a3e7f6d2d2c825 /configure.ac
parentc20b03af2350d4b4f41ca85ffc70e47bf8971bb0 (diff)
* configure.ac: When bootstrapping with GCC, add -std=c++98 to CXX.
* configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@223692 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4da04b76fdf..431cb170e16 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1442,6 +1442,12 @@ case "$have_compiler:$host:$target:$enable_bootstrap" in
;;
esac
+# When bootstrapping with GCC, build stage 1 in C++98 mode to ensure that a
+# C++98 compiler can still start the bootstrap.
+if test "$enable_bootstrap:$GXX" = "yes:yes"; then
+ CXX="$CXX -std=c++98"
+fi
+
# Used for setting $lt_cv_objdir
_LT_CHECK_OBJDIR