summaryrefslogtreecommitdiff
path: root/libc/sysdeps/gnu/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'libc/sysdeps/gnu/configure.in')
-rw-r--r--libc/sysdeps/gnu/configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/libc/sysdeps/gnu/configure.in b/libc/sysdeps/gnu/configure.in
index 3422007ff..b8fd74cff 100644
--- a/libc/sysdeps/gnu/configure.in
+++ b/libc/sysdeps/gnu/configure.in
@@ -25,12 +25,18 @@ case "$prefix" in
libc_cv_slibdir=/lib
;;
esac
- # Allow the user to override the path with --sysconfdir
+ # Allow the user to override the path with --sysconfdir.
if test "$sysconfdir" = '${prefix}/etc'; then
libc_cv_sysconfdir=/etc
else
libc_cv_sysconfdir=$sysconfdir
fi
+ # Allow the user to override the path with --localstatedir.
+ if test "$localstatedir" = '${prefix}/var'; then
+ libc_cv_localstatedir=/var
+ else
+ libc_cv_localstatedir=$localstatedir
+ fi
libc_cv_rootsbindir=/sbin
;;
esac