summaryrefslogtreecommitdiff
path: root/libc/ports/sysdeps
diff options
context:
space:
mode:
authorjoseph <joseph@7b3dc134-2b1b-0410-93df-9e9f96275f8d>2012-07-03 19:42:25 +0000
committerjoseph <joseph@7b3dc134-2b1b-0410-93df-9e9f96275f8d>2012-07-03 19:42:25 +0000
commit20f73aac36c2b2c240dcc379d5117488fe44960c (patch)
treec92a56fb1b39fc4a7c9a012c36b668b2d200b0d0 /libc/ports/sysdeps
parentf6c15fd48a4bf9a3675dc4570f9a06eef0e04096 (diff)
Merge changes between r19447 and r19464 from /fsf/trunk.
git-svn-id: svn://svn.eglibc.org/trunk@19465 7b3dc134-2b1b-0410-93df-9e9f96275f8d
Diffstat (limited to 'libc/ports/sysdeps')
-rw-r--r--libc/ports/sysdeps/arm/Makefile8
-rw-r--r--libc/ports/sysdeps/powerpc/dl-procinfo.c5
-rw-r--r--libc/ports/sysdeps/powerpc/dl-procinfo.h17
3 files changed, 22 insertions, 8 deletions
diff --git a/libc/ports/sysdeps/arm/Makefile b/libc/ports/sysdeps/arm/Makefile
index 69a5a6a11..355f5b309 100644
--- a/libc/ports/sysdeps/arm/Makefile
+++ b/libc/ports/sysdeps/arm/Makefile
@@ -1,8 +1,16 @@
+gnulib-arch = $(elfobjdir)/libgcc-stubs.a
+static-gnulib-arch = $(elfobjdir)/libgcc-stubs.a
+
ifeq ($(subdir),elf)
sysdep-dl-routines += tlsdesc dl-tlsdesc
sysdep_routines += aeabi_unwind_cpp_pr1 find_exidx tlsdesc dl-tlsdesc
sysdep-rtld-routines += aeabi_unwind_cpp_pr1 tlsdesc dl-tlsdesc
shared-only-routines += aeabi_unwind_cpp_pr1
+
+$(objpfx)libgcc-stubs.a: $(objpfx)aeabi_unwind_cpp_pr1.os
+ $(build-extra-lib)
+
+lib-noranlib: $(objpfx)libgcc-stubs.a
endif
ifeq ($(subdir),csu)
diff --git a/libc/ports/sysdeps/powerpc/dl-procinfo.c b/libc/ports/sysdeps/powerpc/dl-procinfo.c
index b1979ab1f..00cd497a2 100644
--- a/libc/ports/sysdeps/powerpc/dl-procinfo.c
+++ b/libc/ports/sysdeps/powerpc/dl-procinfo.c
@@ -1,5 +1,5 @@
/* Data for processor capability information. PowerPC version.
- Copyright (C) 2005, 2006, 2008 Free Software Foundation, Inc.
+ Copyright (C) 2005-2012 Free Software Foundation, Inc.
This file is part of the GNU C Library.
The GNU C Library is free software; you can redistribute it and/or
@@ -67,7 +67,7 @@ PROCINFO_CLASS const char _dl_powerpc_cap_flags[25][10]
#if !defined PROCINFO_DECL && defined SHARED
._dl_powerpc_platforms
#else
-PROCINFO_CLASS const char _dl_powerpc_platforms[12][12]
+PROCINFO_CLASS const char _dl_powerpc_platforms[13][12]
#endif
#ifndef PROCINFO_DECL
= {
@@ -79,6 +79,7 @@ PROCINFO_CLASS const char _dl_powerpc_platforms[12][12]
[PPC_PLATFORM_CELL_BE] = "ppc-cell-be",
[PPC_PLATFORM_POWER6X] = "power6x",
[PPC_PLATFORM_POWER7] = "power7",
+ [PPC_PLATFORM_PPCA2] = "ppca2",
[PPC_PLATFORM_PPC405] = "ppc405",
[PPC_PLATFORM_PPC440] = "ppc440",
[PPC_PLATFORM_PPC464] = "ppc464",
diff --git a/libc/ports/sysdeps/powerpc/dl-procinfo.h b/libc/ports/sysdeps/powerpc/dl-procinfo.h
index 785bd1ba0..98c37757a 100644
--- a/libc/ports/sysdeps/powerpc/dl-procinfo.h
+++ b/libc/ports/sysdeps/powerpc/dl-procinfo.h
@@ -1,5 +1,5 @@
/* Processor capability information handling macros. PowerPC version.
- Copyright (C) 2005, 2006, 2008 Free Software Foundation, Inc.
+ Copyright (C) 2005-2012 Free Software Foundation, Inc.
This file is part of the GNU C Library.
The GNU C Library is free software; you can redistribute it and/or
@@ -30,7 +30,7 @@
#define HWCAP_IMPORTANT (PPC_FEATURE_HAS_ALTIVEC \
+ PPC_FEATURE_HAS_DFP)
-#define _DL_PLATFORMS_COUNT 12
+#define _DL_PLATFORMS_COUNT 13
#define _DL_FIRST_PLATFORM 32
/* Mask to filter out platforms. */
@@ -46,10 +46,11 @@
#define PPC_PLATFORM_CELL_BE 5
#define PPC_PLATFORM_POWER6X 6
#define PPC_PLATFORM_POWER7 7
-#define PPC_PLATFORM_PPC405 8
-#define PPC_PLATFORM_PPC440 9
-#define PPC_PLATFORM_PPC464 10
-#define PPC_PLATFORM_PPC476 11
+#define PPC_PLATFORM_PPCA2 8
+#define PPC_PLATFORM_PPC405 9
+#define PPC_PLATFORM_PPC440 10
+#define PPC_PLATFORM_PPC464 11
+#define PPC_PLATFORM_PPC476 12
static inline const char *
__attribute__ ((unused))
@@ -127,6 +128,10 @@ _dl_string_platform (const char *str)
== 0)
return _DL_FIRST_PLATFORM + PPC_PLATFORM_CELL_BE;
else if (strcmp (str + 3,
+ GLRO(dl_powerpc_platforms)[PPC_PLATFORM_PPCA2] + 3)
+ == 0)
+ return _DL_FIRST_PLATFORM + PPC_PLATFORM_PPCA2;
+ else if (strcmp (str + 3,
GLRO(dl_powerpc_platforms)[PPC_PLATFORM_PPC405] + 3)
== 0)
return _DL_FIRST_PLATFORM + PPC_PLATFORM_PPC405;