aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJacob Bachmeyer <jcb@gnu.org>2020-11-09 21:59:21 -0600
committerJacob Bachmeyer <jcb@gnu.org>2020-11-09 21:59:21 -0600
commit2a33c9e6a64107f1455ecdd52ba0d8b52e5c6d71 (patch)
treecd42a3be58f6b590f9027e75bd94f7fabeb99e03 /configure.ac
parent3d62df24deedfb3c7c3e396a31b8ce431138eb49 (diff)
Revert "Add hook to put branch and evision in the version for development builds."
This reverts commit 1a76740eff41f63e64f1e65e930ad286f357362c. This caused problems (reported in PR44462 as a secondary issue) when a source tree is copied out of a Git directory. A better solution will be developed for the 1.6.4 release that also tags development versions when run from Git working directories without relying on an installation hook. The problem can be demonstrated with: git -z ls-files | cpio -0dp /tmp/dejagnu-test-src followed by configuring in that non-Git copy of the source tree.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 1 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 71bff39..40ee6cc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -59,11 +59,6 @@ then
DEJAGNU="/dev/null"
fi
AC_SUBST(DEJAGNU)
-
-# See what branch we're in
-# FIXME: this will need to deal with a release branch and
-# do something different
-BRANCH=$(cd ${srcdir} && git branch | grep '^\*' | cut -d ' ' -f 2)
-AC_SUBST(BRANCH)
+dnl Makefile.am arranges for DEJAGNU to be exported in the environment.
AC_OUTPUT([Makefile])