aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Elliston <bje@gnu.org>2004-02-08 02:03:16 +0000
committerBen Elliston <bje@gnu.org>2004-02-08 02:03:16 +0000
commitf4c26a04b436e66c8b448fc1ab78a84257fd3e63 (patch)
treec6f3456a560a5ca8c72e2bb0c1872e294bfd573d /configure.ac
parent15f2343a5aad4bdfc63d4c65692e16ae51c143ce (diff)
* configure.ac: Use AC_PATH_PROG to find expect(1).
(DJ_AC_PATH_TCLSH): Remove unneeded invocation. * acinclude.m4 (DJ_AC_PATH_TCLSH): Remove (unused). (DJ_AC_STL): Likewise. * configure: Regenerate. * aclocal.m4: Likewise. * configure: Likewise. * Makefile.in: Likewise. * doc/Makefile.in: Likewise. * example/Makefile.in: Likewise. * testsuite/Makefile.in: Likewise. * testsuite/libdejagnu/Makefile.in: Likewise. * TODO: Update.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 5 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6451fd6..c40dbcf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,15 +10,16 @@ AC_PROG_CC
AC_PROG_CXX
AC_PROG_INSTALL
AC_EXEEXT
-
AC_PROG_YACC
+AC_PATH_PROG(EXPECT, expect)
+if test -z $ac_cv_path_EXPECT ; then
+ AC_MSG_ERROR([unable to locate expect])
+fi
+
dnl we need the path to Docbook so we can build packages.
DJ_AC_PATH_DOCBOOK
-dnl we need the path to the tcl shell to build a release
-DJ_AC_PATH_TCLSH
-
dnl Level of indirection for automake macro (baseboards:boards_DATA)
BOARDS='$(boards)'
AC_SUBST(BOARDS)