summaryrefslogtreecommitdiff
path: root/hw/cxl/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'hw/cxl/meson.build')
-rw-r--r--hw/cxl/meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/hw/cxl/meson.build b/hw/cxl/meson.build
index e68eea2358..f117b99949 100644
--- a/hw/cxl/meson.build
+++ b/hw/cxl/meson.build
@@ -3,4 +3,10 @@ softmmu_ss.add(when: 'CONFIG_CXL',
'cxl-component-utils.c',
'cxl-device-utils.c',
'cxl-mailbox-utils.c',
+ 'cxl-host.c',
+ ),
+ if_false: files(
+ 'cxl-host-stubs.c',
))
+
+softmmu_ss.add(when: 'CONFIG_ALL', if_true: files('cxl-host-stubs.c'))