summaryrefslogtreecommitdiff
path: root/crypto/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'crypto/meson.build')
-rw-r--r--crypto/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/crypto/meson.build b/crypto/meson.build
index 9bf3a431fe..19c44bea89 100644
--- a/crypto/meson.build
+++ b/crypto/meson.build
@@ -50,7 +50,7 @@ if gcrypt.found()
util_ss.add(gcrypt, files('random-gcrypt.c'))
elif gnutls.found()
util_ss.add(gnutls, files('random-gnutls.c'))
-elif 'CONFIG_RNG_NONE' in config_host
+elif get_option('rng_none')
util_ss.add(files('random-none.c'))
else
util_ss.add(files('random-platform.c'))