summaryrefslogtreecommitdiff
path: root/crypto/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'crypto/meson.build')
-rw-r--r--crypto/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/crypto/meson.build b/crypto/meson.build
index f3bab7c067..e2f25810fc 100644
--- a/crypto/meson.build
+++ b/crypto/meson.build
@@ -28,6 +28,8 @@ if nettle.found()
endif
elif gcrypt.found()
crypto_ss.add(gcrypt, files('hash-gcrypt.c', 'hmac-gcrypt.c', 'pbkdf-gcrypt.c'))
+elif gnutls_crypto.found()
+ crypto_ss.add(gnutls, files('hash-gnutls.c', 'hmac-glib.c', 'pbkdf-stub.c')
else
crypto_ss.add(files('hash-glib.c', 'hmac-glib.c', 'pbkdf-stub.c'))
endif