summaryrefslogtreecommitdiff
path: root/util/meson.build
diff options
context:
space:
mode:
authorVladimir Sementsov-Ogievskiy <vsementsov@openvz.org>2022-04-07 16:27:23 +0300
committerVladimir Sementsov-Ogievskiy <vsementsov@yandex-team.ru>2022-06-29 10:56:12 +0300
commite1878eb5f0d93a67deb46aaeea898cf4824a759a (patch)
tree6601b84c8a70c4cad699e0d65f9c4f318a5021c8 /util/meson.build
parentdd3e97dfbe199fa277869d127884071100a426e5 (diff)
util: add qemu-co-timeout
Add new API, to make a time limited call of the coroutine. Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov@openvz.org> Reviewed-by: Hanna Reitz <hreitz@redhat.com> Signed-off-by: Vladimir Sementsov-Ogievskiy <vsementsov@yandex-team.ru>
Diffstat (limited to 'util/meson.build')
-rw-r--r--util/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/util/meson.build b/util/meson.build
index 4939b0b91c..8cce8f8968 100644
--- a/util/meson.build
+++ b/util/meson.build
@@ -85,6 +85,7 @@ if have_block
util_ss.add(files('block-helpers.c'))
util_ss.add(files('qemu-coroutine-sleep.c'))
util_ss.add(files('qemu-co-shared-resource.c'))
+ util_ss.add(files('qemu-co-timeout.c'))
util_ss.add(files('thread-pool.c', 'qemu-timer.c'))
util_ss.add(files('readline.c'))
util_ss.add(files('throttle.c'))