summaryrefslogtreecommitdiff
path: root/ui/meson.build
diff options
context:
space:
mode:
authorGerd Hoffmann <kraxel@redhat.com>2021-05-19 07:39:38 +0200
committerGerd Hoffmann <kraxel@redhat.com>2021-05-21 09:42:44 +0200
commit0bf41cab93e5c72dcda717abd625698b59d9ba3e (patch)
tree9f240856fecebcdf5c11adf1a3879fa318820b6c /ui/meson.build
parentf0349f4d8947ad32d0fa4678cbf5dbb356fcbda1 (diff)
ui/vnc: clipboard support
This patch adds support for cut+paste to the qemu vnc server, which allows the vnc client exchange clipbaord data with qemu and other peers like the qemu vdagent implementation. Signed-off-by: Gerd Hoffmann <kraxel@redhat.com> Reviewed-by: Marc-André Lureau <marcandre.lureau@redhat.com> Message-id: 20210519053940.1888907-1-kraxel@redhat.com Message-Id: <20210519053940.1888907-8-kraxel@redhat.com>
Diffstat (limited to 'ui/meson.build')
-rw-r--r--ui/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/ui/meson.build b/ui/meson.build
index bad49fb6de..f37ef882e0 100644
--- a/ui/meson.build
+++ b/ui/meson.build
@@ -30,6 +30,7 @@ vnc_ss.add(files(
'vnc-auth-vencrypt.c',
'vnc-ws.c',
'vnc-jobs.c',
+ 'vnc-clipboard.c',
))
vnc_ss.add(zlib, png, jpeg, gnutls)
vnc_ss.add(when: sasl, if_true: files('vnc-auth-sasl.c'))