summaryrefslogtreecommitdiff
path: root/qom/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2020-08-04 21:14:26 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2020-08-21 06:30:22 -0400
commitff219dca9ffa4c3417f8a00ef7ce3e9a15196eb0 (patch)
tree2fb0364c9b820b758dc54aa5e5da3221b589378c /qom/meson.build
parent708eab42dc75304473f23ea1ead06d579dcb7566 (diff)
meson: convert common QMP bits for qemu and qemu-storage-daemon
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'qom/meson.build')
-rw-r--r--qom/meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/qom/meson.build b/qom/meson.build
index cbab9cdfa2..a1cd03c82c 100644
--- a/qom/meson.build
+++ b/qom/meson.build
@@ -7,6 +7,9 @@ qom_ss.add(files(
'qom-qobject.c',
))
+qmp_ss.add(files('qom-qmp-cmds.c'))
+softmmu_ss.add(files('qom-hmp-cmds.c'))
+
qom_ss = qom_ss.apply(config_host, strict: false)
libqom = static_library('qom', qom_ss.sources() + genh,
dependencies: [qom_ss.dependencies()],