summaryrefslogtreecommitdiff
path: root/qga/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2022-02-02 10:14:49 +0100
committerPaolo Bonzini <pbonzini@redhat.com>2022-02-21 10:35:54 +0100
commite23460ce921168b4172af83043e87ca9bd85e43b (patch)
tree3afaa5ec30e2d4fb3c85b72b63cb0160b4f14c73 /qga/meson.build
parent23011f44d79aa982b9dbb21ffabadf0fa89066bd (diff)
meson: require dynamic linking for VSS support
The glib_dynamic detection does not work because the dependency is overridden in the main meson.build. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> [Rewritten commit message, added requirement in qga/meson.build - Paolo] Reviewed-by: Philippe Mathieu-Daudé <f4bug@amsat.org> Reviewed-by: Konstantin Kostiuk <kkostiuk@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'qga/meson.build')
-rw-r--r--qga/meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/qga/meson.build b/qga/meson.build
index 4ac781cb33..d22ecb4187 100644
--- a/qga/meson.build
+++ b/qga/meson.build
@@ -22,6 +22,8 @@ have_qga_vss = get_option('qga_vss') \
Then run configure with: --extra-cxxflags="-isystem /path/to/vss/inc/win2003"''') \
.require(midl.found() or widl.found(),
error_message: 'VSS support requires midl or widl') \
+ .require(not enable_static,
+ error_message: 'VSS support requires dynamic linking with GLib') \
.allowed()
all_qga = []