summaryrefslogtreecommitdiff
path: root/qga/meson.build
diff options
context:
space:
mode:
authorPaolo Bonzini <pbonzini@redhat.com>2020-08-05 13:07:48 +0200
committerPaolo Bonzini <pbonzini@redhat.com>2020-08-21 06:30:42 -0400
commitacfdaac577130e86ebefe5564cfd121c16dbc3c4 (patch)
treee77a0822082ff21e6f092e935dfce4f771dab1dd /qga/meson.build
parentbac35bf5175fb16470a73492c23161e80361eeeb (diff)
meson: build texi doc
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'qga/meson.build')
-rw-r--r--qga/meson.build12
1 files changed, 9 insertions, 3 deletions
diff --git a/qga/meson.build b/qga/meson.build
index 2b91261427..3f28f74b52 100644
--- a/qga/meson.build
+++ b/qga/meson.build
@@ -1,7 +1,6 @@
qga_qapi_outputs = [
'qga-qapi-commands.c',
'qga-qapi-commands.h',
- 'qga-qapi-doc.texi',
'qga-qapi-emit-events.c',
'qga-qapi-emit-events.h',
'qga-qapi-events.c',
@@ -17,12 +16,19 @@ qga_qapi_outputs = [
]
qga_qapi_files = custom_target('QGA QAPI files',
- output: qga_qapi_outputs,
+ output: qga_qapi_outputs + ['qga-qapi-doc.texi'],
input: 'qapi-schema.json',
command: [ qapi_gen, '-o', 'qga', '-p', 'qga-', '@INPUT0@' ],
depend_files: qapi_gen_depends)
+
qga_ss = ss.source_set()
-qga_ss.add(qga_qapi_files)
+i = 0
+foreach output: qga_qapi_outputs
+ qga_ss.add(qga_qapi_files[i])
+ i = i + 1
+endforeach
+qga_qapi_doc_texi = qga_qapi_files[i]
+
qga_ss.add(files(
'commands.c',
'guest-agent-command-state.c',