summaryrefslogtreecommitdiff
path: root/qga/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2022-04-01 12:51:06 +0400
committerPaolo Bonzini <pbonzini@redhat.com>2022-04-06 14:31:55 +0200
commit3015321dc49a1e702a7fcc242ed7233d46d27209 (patch)
tree638d864b842178043653bfcf8f88f95fba996cae /qga/meson.build
parent0f9668e0c197ab6de95f61a906703a1d127c11f8 (diff)
build-sys: drop ntddscsi.h check
The header has been part of MinGW-w64 since the introduction of the project (2007). While on MinGW(32), the legacy project, it was imported in 2014 from w32api-3.17 (commit e4803e0da2). According to build-platform.rst and our CI coverage, we only support building with MinGW-w64 (from Debian/Fedora). Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Reviewed-by: Konstantin Kostiuk <kkostiuk@redhat.com> Message-Id: <20220401085106.2167374-1-marcandre.lureau@redhat.com> Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
Diffstat (limited to 'qga/meson.build')
-rw-r--r--qga/meson.build6
1 files changed, 2 insertions, 4 deletions
diff --git a/qga/meson.build b/qga/meson.build
index 62472747f1..392d560941 100644
--- a/qga/meson.build
+++ b/qga/meson.build
@@ -83,14 +83,12 @@ qga_ss = qga_ss.apply(config_host, strict: false)
gen_tlb = []
qga_libs = []
if targetos == 'windows'
- qga_libs += ['-lws2_32', '-lwinmm', '-lpowrprof', '-lwtsapi32', '-lwininet', '-liphlpapi', '-lnetapi32']
+ qga_libs += ['-lws2_32', '-lwinmm', '-lpowrprof', '-lwtsapi32', '-lwininet', '-liphlpapi', '-lnetapi32',
+ '-lsetupapi', '-lcfgmgr32']
if have_qga_vss
qga_libs += ['-lole32', '-loleaut32', '-lshlwapi', '-lstdc++', '-Wl,--enable-stdcall-fixup']
subdir('vss-win32')
endif
- if have_ntddscsi
- qga_libs += ['-lsetupapi', '-lcfgmgr32']
- endif
endif
qga = executable('qemu-ga', qga_ss.sources(),