summaryrefslogtreecommitdiff
path: root/qga/meson.build
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2022-05-25 16:41:30 +0200
committerMarc-André Lureau <marcandre.lureau@redhat.com>2022-05-28 11:42:56 +0200
commit0edbfbe31c532a98a8674b68c94a97537f4e4230 (patch)
tree720f1315c8e9ee3e21b30dd35514b04dd8adca9c /qga/meson.build
parent69f56c140de06fee0f266b93634475e1d968e430 (diff)
qga: add qga_open_cloexec() helper
QGA calls qemu_open_old() in various places. Calling qemu_open() instead isn't a great alternative, as it has special "/dev/fdset" handling and depends on QEMU internal monitor data structures. Instead, provide a simple helper for QGA needs, with Error* support. The following patches will make use of it. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com> Reviewed-by: Markus Armbruster <armbru@redhat.com> Message-Id: <20220525144140.591926-6-marcandre.lureau@redhat.com>
Diffstat (limited to 'qga/meson.build')
-rw-r--r--qga/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/qga/meson.build b/qga/meson.build
index 6d9f39bb32..35fe2229e9 100644
--- a/qga/meson.build
+++ b/qga/meson.build
@@ -65,6 +65,7 @@ qga_ss.add(files(
'commands.c',
'guest-agent-command-state.c',
'main.c',
+ 'cutils.c',
))
qga_ss.add(when: 'CONFIG_POSIX', if_true: files(
'channel-posix.c',