summaryrefslogtreecommitdiff
path: root/hw/acpi/meson.build
diff options
context:
space:
mode:
authorPhilippe Mathieu-Daudé <philmd@redhat.com>2021-05-21 16:01:36 +0200
committerPhilippe Mathieu-Daudé <philmd@redhat.com>2021-07-20 15:26:26 +0200
commit0afdee11d6267dc37335122afa9a6b7080522d3a (patch)
tree204b21ccb4bac88c314db94277e94c3dcd533954 /hw/acpi/meson.build
parent39f6049e47bc1c53687af06e065d9b83311fa216 (diff)
hw/acpi: Do not restrict ACPI core routines to x86 architecture
ACPI core routines (in core.c) are not really x86-specific. Signed-off-by: Philippe Mathieu-Daudé <philmd@redhat.com> Acked-by: Michael S. Tsirkin <mst@redhat.com> Message-Id: <20210616204328.2611406-21-philmd@redhat.com>
Diffstat (limited to 'hw/acpi/meson.build')
-rw-r--r--hw/acpi/meson.build3
1 files changed, 2 insertions, 1 deletions
diff --git a/hw/acpi/meson.build b/hw/acpi/meson.build
index 9b7fa75719..29f804d13e 100644
--- a/hw/acpi/meson.build
+++ b/hw/acpi/meson.build
@@ -3,6 +3,7 @@ acpi_ss.add(files(
'acpi_interface.c',
'aml-build.c',
'bios-linker-loader.c',
+ 'core.c',
'utils.c',
))
acpi_ss.add(when: 'CONFIG_ACPI_CPU_HOTPLUG', if_true: files('cpu.c'))
@@ -14,7 +15,7 @@ acpi_ss.add(when: 'CONFIG_ACPI_VMGENID', if_true: files('vmgenid.c'))
acpi_ss.add(when: 'CONFIG_ACPI_HW_REDUCED', if_true: files('generic_event_device.c'))
acpi_ss.add(when: 'CONFIG_ACPI_HMAT', if_true: files('hmat.c'))
acpi_ss.add(when: 'CONFIG_ACPI_APEI', if_true: files('ghes.c'), if_false: files('ghes-stub.c'))
-acpi_ss.add(when: 'CONFIG_ACPI_X86', if_true: files('core.c', 'piix4.c', 'pcihp.c'), if_false: files('acpi-stub.c'))
+acpi_ss.add(when: 'CONFIG_ACPI_X86', if_true: files('piix4.c', 'pcihp.c'))
acpi_ss.add(when: 'CONFIG_ACPI_X86_ICH', if_true: files('ich9.c', 'tco.c'))
acpi_ss.add(when: 'CONFIG_IPMI', if_true: files('ipmi.c'), if_false: files('ipmi-stub.c'))
acpi_ss.add(when: 'CONFIG_PC', if_false: files('acpi-x86-stub.c'))