summaryrefslogtreecommitdiff
path: root/libunwind/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2017-12-05 20:48:05 +0000
committerPetr Hosek <phosek@chromium.org>2017-12-05 20:48:05 +0000
commite71fb0494bdf00fd21a135bc3bd8d15b2c2f8c32 (patch)
treedad6ca37e68ff2dbde3b7832175cb75cc3f932d1 /libunwind/CMakeLists.txt
parent5c1feebe1c76ad9f08c2a25dd958fb7b15de8b5d (diff)
[libunwind][CMake] Set TARGET_TRIPLE if LIBUNWND_TARGET_TRIPLE is set
This follows the setup used by other runtimes and is expected by the lit configuration. Differential Revision: https://reviews.llvm.org/D40820
Diffstat (limited to 'libunwind/CMakeLists.txt')
-rw-r--r--libunwind/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/libunwind/CMakeLists.txt b/libunwind/CMakeLists.txt
index f8ede54ca63..b28e4d0ef84 100644
--- a/libunwind/CMakeLists.txt
+++ b/libunwind/CMakeLists.txt
@@ -211,6 +211,10 @@ add_target_flags_if(LIBUNWIND_GCC_TOOLCHAIN
add_target_flags_if(LIBUNWIND_SYSROOT
"--sysroot=${LIBUNWIND_SYSROOT}")
+if (LIBUNWIND_TARGET_TRIPLE)
+ set(TARGET_TRIPLE "${LIBUNWIND_TARGET_TRIPLE}")
+endif()
+
# Configure compiler.
include(config-ix)