summaryrefslogtreecommitdiff
path: root/libunwind/CMakeLists.txt
diff options
context:
space:
mode:
authorJonathan Roelofs <jonathan@codesourcery.com>2017-03-28 15:21:43 +0000
committerJonathan Roelofs <jonathan@codesourcery.com>2017-03-28 15:21:43 +0000
commite4e68d5124022161d19875f8ed927e0bed5014d8 (patch)
tree12595b53d38eb42d239629c39ccf27e860d86541 /libunwind/CMakeLists.txt
parent8b26884ede5f6357a17b6b62a1729c4a177179a3 (diff)
[libunwind] Add sphinx docs
https://reviews.llvm.org/D31375
Diffstat (limited to 'libunwind/CMakeLists.txt')
-rw-r--r--libunwind/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/libunwind/CMakeLists.txt b/libunwind/CMakeLists.txt
index 32c215c6580..41a771c7490 100644
--- a/libunwind/CMakeLists.txt
+++ b/libunwind/CMakeLists.txt
@@ -122,6 +122,7 @@ option(LIBUNWIND_ENABLE_STATIC "Build libunwind as a static library." ON)
option(LIBUNWIND_ENABLE_CROSS_UNWINDING "Enable cross-platform unwinding support." OFF)
option(LIBUNWIND_ENABLE_ARM_WMMX "Enable unwinding support for ARM WMMX registers." OFF)
option(LIBUNWIND_ENABLE_THREADS "Build libunwind with threading support." ON)
+option(LIBUNWIND_INCLUDE_DOCS "Build the libunwind documentation." ${LLVM_INCLUDE_DOCS})
set(LIBUNWIND_TARGET_TRIPLE "" CACHE STRING "Target triple for cross compiling.")
set(LIBUNWIND_GCC_TOOLCHAIN "" CACHE PATH "GCC toolchain for cross compiling.")
@@ -303,3 +304,7 @@ if (NOT LIBUNWIND_CXX_INCLUDE_PATHS STREQUAL "")
endif()
add_subdirectory(src)
+
+if (LIBUNWIND_INCLUDE_DOCS)
+ add_subdirectory(docs)
+endif()