summaryrefslogtreecommitdiff
path: root/libunwind/CMakeLists.txt
diff options
context:
space:
mode:
authorCharles Davis <cdavis5x@gmail.com>2018-09-04 20:57:50 +0000
committerCharles Davis <cdavis5x@gmail.com>2018-09-04 20:57:50 +0000
commit92816bf540d5a299749d38cabfcda5f28b6f5f9f (patch)
tree31a64827bae55bdfaf4f5c70e46f1b9337253e81 /libunwind/CMakeLists.txt
parent728857ee2824f05369f53a9360c3e8734fb3354a (diff)
[CMake] Don't use -rtlib=compiler-rt with -nodefaultlibs.
Summary: This switch only has an effect at link time. It changes the default compiler support library to `compiler-rt`. With `-nodefaultlibs`, this library won't get linked anyway; Clang actually warns about that. Reviewers: mstorsjo, rnk Subscribers: dberris, mgorny, christof, cfe-commits Differential Revision: https://reviews.llvm.org/D51645
Diffstat (limited to 'libunwind/CMakeLists.txt')
-rw-r--r--libunwind/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/libunwind/CMakeLists.txt b/libunwind/CMakeLists.txt
index d73c0ddfb60..bab9e08fde8 100644
--- a/libunwind/CMakeLists.txt
+++ b/libunwind/CMakeLists.txt
@@ -234,7 +234,7 @@ endif()
# Configure compiler.
include(config-ix)
-if (LIBUNWIND_USE_COMPILER_RT)
+if (LIBUNWIND_USE_COMPILER_RT AND NOT LIBUNWIND_HAS_NODEFAULTLIBS_FLAG)
list(APPEND LIBUNWIND_LINK_FLAGS "-rtlib=compiler-rt")
endif()