summaryrefslogtreecommitdiff
path: root/clang-tools-extra/unittests/clangd/CMakeLists.txt
diff options
context:
space:
mode:
authorIlya Biryukov <ibiryukov@google.com>2018-11-26 15:25:20 +0000
committerIlya Biryukov <ibiryukov@google.com>2018-11-26 15:25:20 +0000
commit70f604d5726ad0aab17166ef0ff710e177f17b1a (patch)
tree4bcb1cf76a71a07f4618586614a4d9884b160885 /clang-tools-extra/unittests/clangd/CMakeLists.txt
parent75cc186aa52052986af3bee0d62164778ec02e0e (diff)
[clangd] Initial implementation of expected types
Summary: Provides facilities to model the C++ conversion rules without the AST. The introduced representation can be stored in the index and used to implement type-based ranking improvements for index-based completions. Reviewers: sammccall, ioeric Reviewed By: sammccall Subscribers: malaperle, mgorny, MaskRay, jkorous, arphaman, kadircet, cfe-commits Differential Revision: https://reviews.llvm.org/D52273
Diffstat (limited to 'clang-tools-extra/unittests/clangd/CMakeLists.txt')
-rw-r--r--clang-tools-extra/unittests/clangd/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/clang-tools-extra/unittests/clangd/CMakeLists.txt b/clang-tools-extra/unittests/clangd/CMakeLists.txt
index b6233b07f94..8ac440e444e 100644
--- a/clang-tools-extra/unittests/clangd/CMakeLists.txt
+++ b/clang-tools-extra/unittests/clangd/CMakeLists.txt
@@ -19,6 +19,7 @@ add_extra_unittest(ClangdTests
ContextTests.cpp
DexTests.cpp
DraftStoreTests.cpp
+ ExpectedTypeTest.cpp
FileDistanceTests.cpp
FileIndexTests.cpp
FindSymbolsTests.cpp