summaryrefslogtreecommitdiff
path: root/clang-tools-extra/unittests/clangd/CMakeLists.txt
diff options
context:
space:
mode:
authorIlya Biryukov <ibiryukov@google.com>2018-02-12 11:37:28 +0000
committerIlya Biryukov <ibiryukov@google.com>2018-02-12 11:37:28 +0000
commit59620e541367ae60b762b3216667314b5b6b8c9b (patch)
tree152d1abf34af1f4bc0430b4486a6789e5ad0a936 /clang-tools-extra/unittests/clangd/CMakeLists.txt
parent2b625e498eb6f4b0920fc4af16998a59489510fe (diff)
[clangd] Remove codeComplete that returns std::future<>
Summary: It was deprecated and callback version and is used everywhere. Only changes to the testing code were needed. Reviewers: hokein, ioeric, sammccall Reviewed By: sammccall Subscribers: mgorny, klimek, jkorous-apple, cfe-commits Differential Revision: https://reviews.llvm.org/D43068
Diffstat (limited to 'clang-tools-extra/unittests/clangd/CMakeLists.txt')
-rw-r--r--clang-tools-extra/unittests/clangd/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/clang-tools-extra/unittests/clangd/CMakeLists.txt b/clang-tools-extra/unittests/clangd/CMakeLists.txt
index c0cba6c817f..c85f629bc8a 100644
--- a/clang-tools-extra/unittests/clangd/CMakeLists.txt
+++ b/clang-tools-extra/unittests/clangd/CMakeLists.txt
@@ -19,13 +19,14 @@ add_extra_unittest(ClangdTests
FuzzyMatchTests.cpp
IndexTests.cpp
JSONExprTests.cpp
- URITests.cpp
+ SourceCodeTests.cpp
+ SymbolCollectorTests.cpp
+ SyncAPI.cpp
TestFS.cpp
ThreadingTests.cpp
TraceTests.cpp
TUSchedulerTests.cpp
- SourceCodeTests.cpp
- SymbolCollectorTests.cpp
+ URITests.cpp
XRefsTests.cpp
)