summaryrefslogtreecommitdiff
path: root/zlib/Makefile.am
diff options
context:
space:
mode:
authorTom Tromey <tromey@cygnus.com>1999-06-21 13:03:47 +0000
committerTom Tromey <tromey@gcc.gnu.org>1999-06-21 13:03:47 +0000
commitb48ed5683a719c42d69bed15028ff177d12ede62 (patch)
tree3eb065174a652092763e1549b98f6df22f1939c4 /zlib/Makefile.am
parentb1b9b120a47d828987d11fe921fd872bf67c496e (diff)
Makefile.in: Rebuilt.
* Makefile.in: Rebuilt. * Makefile.am (toolexeclibdir): Define as libdir when appropriate. * configure: Rebuilt. * configure.in (USE_LIBDIR): New conditional. From-SVN: r27667
Diffstat (limited to 'zlib/Makefile.am')
-rw-r--r--zlib/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/zlib/Makefile.am b/zlib/Makefile.am
index cf27582dbec..f00bc78a354 100644
--- a/zlib/Makefile.am
+++ b/zlib/Makefile.am
@@ -10,8 +10,14 @@ MULTISUBDIR =
MULTIDO = true
MULTICLEAN = true
+## Install a library built with a cross compiler in tooldir, not
+## libdir.
+if USE_LIBDIR
+toolexeclibdir = $(libdir)
+else
toolexecdir = $(exec_prefix)/$(target_alias)
toolexeclibdir = $(toolexecdir)/lib$(MULTISUBDIR)
+endif
## We don't use `libz.la' because we don't want to conflict with a
## system library of that name.