summaryrefslogtreecommitdiff
path: root/libvtv/configure.ac
diff options
context:
space:
mode:
authorCaroline Tice <cmtice@google.com>2013-09-06 10:56:35 -0700
committerCaroline Tice <ctice@gcc.gnu.org>2013-09-06 10:56:35 -0700
commit87f3fea84f67800856b9ce8ee6f3322991ec29bf (patch)
tree8597d6059bbd847b80076b40a3ce9d664c451360 /libvtv/configure.ac
parent5e8d9b455910f258929e0af04bc4e75ad8909386 (diff)
Add documentation for the options --enable-vtable-verify,
--disable-vtable-verify and --disable-libvtv. Also update configure and make files in libvtv not to use --enable-vtable-verify. From-SVN: r202346
Diffstat (limited to 'libvtv/configure.ac')
-rw-r--r--libvtv/configure.ac19
1 files changed, 2 insertions, 17 deletions
diff --git a/libvtv/configure.ac b/libvtv/configure.ac
index 60350dfccc3..6db97dc60b8 100644
--- a/libvtv/configure.ac
+++ b/libvtv/configure.ac
@@ -20,18 +20,6 @@ AC_ARG_ENABLE(version-specific-runtime-libs,
[version_specific_libs=no])
AC_MSG_RESULT($version_specific_libs)
-# Use same top-level configure hooks in libgcc/libstdc++/libvtv.
-AC_MSG_CHECKING([for --enable-vtable-verify])
-AC_ARG_ENABLE(vtable-verify,
-[ --enable-vtable-verify Enable vtable verification feature ],
-[case "$enableval" in
- yes) enable_vtable_verify=yes ;;
- no) enable_vtable_verify=no ;;
- *) enable_vtable_verify=no;;
- esac],
-[enable_vtable_verify=no])
-AC_MSG_RESULT($enable_vtable_verify)
-
# See if supported.
unset VTV_SUPPORTED
AC_MSG_CHECKING([for host support for vtable verification])
@@ -41,12 +29,9 @@ AC_MSG_RESULT($VTV_SUPPORTED)
# Decide if it's usable.
use_vtable_verify=no
if test "x$VTV_SUPPORTED" = "xyes"; then
- if test "x$enable_vtable_verify" = "xyes"; then
- use_vtable_verify=yes
- AC_MSG_NOTICE(using vtable verification)
- fi
+ use_vtable_verify=yes
+ AC_MSG_NOTICE(using vtable verification)
fi
-AM_CONDITIONAL(ENABLE_VTABLE_VERIFY, test $use_vtable_verify = yes)
# Do not delete or change the following two lines. For why, see
# http://gcc.gnu.org/ml/libstdc++/2003-07/msg00451.html