summaryrefslogtreecommitdiff
path: root/libssp/configure.ac
diff options
context:
space:
mode:
authorIgor Tsimbalist <igor.v.tsimbalist@intel.com>2017-11-17 23:32:46 +0100
committerIgor Tsimbalist <itsimbal@gcc.gnu.org>2017-11-17 23:32:46 +0100
commitff035ef67334c4a5011d2f28a8b1c5813c1da9d5 (patch)
treed27c32575d5c526f1257183c9e0f5c7621c6717d /libssp/configure.ac
parent8e2fc0551b547d1ecb498d18fc599bc73289629f (diff)
Enable building libssp with Intel CET
libssp/ * Makefile.am: Update AM_CFLAGS, update libssp_nonshared_la_CFLAGS. * Makefile.in: Regenerate. * configure: Likewise. * aclocal.m4: Likewise. * configure.ac: Set CET_FLAGS. Update XCFLAGS. From-SVN: r254898
Diffstat (limited to 'libssp/configure.ac')
-rw-r--r--libssp/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/libssp/configure.ac b/libssp/configure.ac
index 9e4a22a24d4..0d228c17d1a 100644
--- a/libssp/configure.ac
+++ b/libssp/configure.ac
@@ -62,6 +62,11 @@ void __attribute__((noinline)) bar (char *x)
[AC_MSG_RESULT(no)])
CFLAGS="$save_CFLAGS"
+# Add CET specific flags if CET is enabled
+GCC_CET_FLAGS(CET_FLAGS)
+XCFLAGS="$XCFLAGS $CET_FLAGS"
+AC_SUBST(XCFLAGS)
+
AC_MSG_CHECKING([whether hidden visibility is supported])
AC_TRY_COMPILE([
void __attribute__((visibility ("hidden"))) bar (void) {}],,