summaryrefslogtreecommitdiff
path: root/libquadmath/configure.ac
diff options
context:
space:
mode:
authorTobias Burnus <burnus@net-b.de>2010-12-19 20:01:38 +0100
committerTobias Burnus <burnus@gcc.gnu.org>2010-12-19 20:01:38 +0100
commit6f468984d82a1d514b410ffc4d06efdb47a1e526 (patch)
treedb01227b632db0c2224ca36d3088c47e9a6ae426 /libquadmath/configure.ac
parent799fa775605b4e3cef078635fbeaf30bad1960e2 (diff)
re PR fortran/46520 (libquadmath: fails at link test on bare irons)
2010-12-19 Tobias Burnus <burnus@net-b.de> PR fortran/46520 * configure.ac: Do not call AC_CHECK_LIB for gcc_no_link. * configure: Regenerate From-SVN: r168069
Diffstat (limited to 'libquadmath/configure.ac')
-rw-r--r--libquadmath/configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/libquadmath/configure.ac b/libquadmath/configure.ac
index 56b1fcb2792..68b5cf8924c 100644
--- a/libquadmath/configure.ac
+++ b/libquadmath/configure.ac
@@ -109,8 +109,19 @@ esac
AC_SUBST(toolexecdir)
AC_SUBST(toolexeclibdir)
-AC_CHECK_LIB([m],[sqrtl],[AC_DEFINE([HAVE_SQRTL],[1],[libm includes sqrtl])])
-AC_CHECK_LIB([m],[cbrtl],[AC_DEFINE([HAVE_CBRTL],[1],[libm includes cbrtl])])
+# If available, sqrtl and cbrtl speed up the calculation -
+# but they are not required
+if test x$gcc_no_link != xyes; then
+ AC_CHECK_LIB([m],[sqrtl],[AC_DEFINE([HAVE_SQRTL],[1],[libm includes sqrtl])])
+ AC_CHECK_LIB([m],[cbrtl],[AC_DEFINE([HAVE_CBRTL],[1],[libm includes cbrtl])])
+else
+ if test "x$ac_cv_lib_m_sqrtl" = x""yes; then
+ AC_DEFINE([HAVE_SQRTL],[1],[libm includes sqrtl])
+ fi
+ if test "x$ac_cv_lib_m_cbrtl" = x""yes; then
+ AC_DEFINE([HAVE_CBRTL],[1],[libm includes cbrtl])
+ fi
+fi
# Check for symbol versioning (copied from libssp).
AC_MSG_CHECKING([whether symbol versioning is supported])