summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan-Benedict Glaw <jbglaw@lug-owl.de>2014-11-26 21:53:04 +0000
committerJan-Benedict Glaw <jbglaw@gcc.gnu.org>2014-11-26 21:53:04 +0000
commit74ae587edafb8c83ac77fdc9182db76ef123955f (patch)
treec1e9127b6f62777ba9b44a500acc20bf28d91105 /configure.ac
parent2ad2e0afc6e7c7510c340b8de6202ed1f3f9b733 (diff)
Merge toplevel configure.ac bits from Binutils
GCC and Binutils had a common ./configure.ac after this commit: commit 08d081652f50df83f7e9768f8dbb7a99b0df50a2 Author: sandra <sandra@138bc75d-0d04-0410-961f-82ee72b054a4> Date: Wed May 14 23:20:59 2014 +0000 2014-05-14 Sandra Loosemore <sandra@codesourcery.com> * configure.ac (target_makefile_frag): Set for nios2-*-elf*. * configure: Regenerated. config/ * mt-nios2-elf: New file. Based on that file version, all GCC and Binutils commits to this file were applied. This pulls in the following missing Binutils changes to configure.ac: 2014-07-21 Joel Sherrill <joel.sherrill@oarcorp.com> Disable gdb for or1k*-*-* until supported * configure.ac (or1k*-*-*): Disable gdb. * configure: Regenerated. 2014-07-27 Joel Sherrill <joel.sherrill@oarcorp.com> GDB not supported for or1k*-*-rtems* * configure.ac (or1k*-*-rtems*): gdb not supported. The ordering of the stanzas results in this not being caught by or1k*-*-* later. * configure. Regenerated. 2014-09-06 Kuan-Lin Chen <kuanlinchentw@gmail.com> * configure: Disable gdb for nds32*-*-* until supported. * configure.ac: Disable gdb for nds32*-*-* until supported. 2014-09-12 Andrew Bennett <andrew.bennett@imgtec.com> * configure.ac: Add mips*-img-elf* target triple. * configure: Regenerate. For this patch: 2014-11-26 Jan-Benedict Glaw <jbglaw@lug-owl.de> * configure.ac: Merge with Binutils. From-SVN: r218100
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index b27fb1dfdea..fd1bdf0f506 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1010,6 +1010,10 @@ case "${target}" in
;;
*-*-rtems*)
noconfigdirs="$noconfigdirs target-libgloss"
+ # this is not caught below because this stanza matches earlier
+ case $target in
+ or1k*-*-*) noconfigdirs="$noconfigdirs gdb" ;;
+ esac
;;
# The tpf target doesn't support gdb yet.
*-*-tpf*)
@@ -1185,7 +1189,7 @@ case "${target}" in
microblaze*)
noconfigdirs="$noconfigdirs gprof"
;;
- mips*-sde-elf* | mips*-mti-elf*)
+ mips*-sde-elf* | mips*-mti-elf* | mips*-img-elf*)
if test x$with_newlib = xyes; then
noconfigdirs="$noconfigdirs gprof"
fi
@@ -1208,10 +1212,16 @@ case "${target}" in
mips*-*-*)
noconfigdirs="$noconfigdirs gprof"
;;
+ nds32*-*-*)
+ noconfigdirs="$noconfigdirs gdb"
+ ;;
nvptx*-*-*)
# nvptx is just a compiler
noconfigdirs="$noconfigdirs target-libssp target-libstdc++-v3 target-libobjc"
;;
+ or1k*-*-*)
+ noconfigdirs="$noconfigdirs gdb"
+ ;;
sh-*-* | sh64-*-*)
case "${target}" in
sh*-*-elf)
@@ -2454,7 +2464,7 @@ case "${target}" in
spu-*-*)
target_makefile_frag="config/mt-spu"
;;
- mips*-sde-elf* | mips*-mti-elf*)
+ mips*-sde-elf* | mips*-mti-elf* | mips*-img-elf*)
target_makefile_frag="config/mt-sde"
;;
mipsisa*-*-elfoabi*)